summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-08 02:39:52 +0000
committerSam James <sam@gentoo.org>2021-12-08 02:41:15 +0000
commitbf316365f10d66bb16871635d3296819a32a2c61 (patch)
tree99b6f3e64ba6a0312bfe1462bebf988876655d3d /dev-lang
parentdev-lang/reason: new package; add version 3.7.0 (diff)
downloadgentoo-bf316365f10d66bb16871635d3296819a32a2c61.tar.gz
gentoo-bf316365f10d66bb16871635d3296819a32a2c61.tar.bz2
gentoo-bf316365f10d66bb16871635d3296819a32a2c61.zip
dev-lang/python: skip known-hanging/fragile tests for PGO
test_socket was the one reported originally here but others have reported hangs with: - test_asyncio - test_httpservers - test_logging - test_multiprocessing_fork - test_xmlrpc This is consistent with some of the odd hangs I've seen in src_test sporadically. Let's just skip them for PGO for now in lieu of more information. (--verbose for the test suite lives up to its name but isn't necessarily enough to get us what we need?) Bug: https://bugs.gentoo.org/828535 Bug: https://bugs.gentoo.org/788022 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.10.1.ebuild7
-rw-r--r--dev-lang/python/python-3.11.0_alpha2.ebuild7
-rw-r--r--dev-lang/python/python-3.9.9.ebuild7
3 files changed, 18 insertions, 3 deletions
diff --git a/dev-lang/python/python-3.10.1.ebuild b/dev-lang/python/python-3.10.1.ebuild
index 42698f3105cf..d7b21b80cdd7 100644
--- a/dev-lang/python/python-3.10.1.ebuild
+++ b/dev-lang/python/python-3.10.1.ebuild
@@ -162,7 +162,12 @@ src_configure() {
if use pgo; then
local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
- export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb"
+ export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb -u-network"
+
+ # All of these seem to occasionally hang for PGO inconsistently
+ # They'll even hang here but be fine in src_test sometimes.
+ # bug #828535 (and related: bug #788022)
+ PROFILE_TASK+=" -x test_socket -x test_asyncio -x test_httpservers -x test_logging -x test_multiprocessing_fork -x test_xmlrpc"
if has_version "app-arch/rpm" ; then
# Avoid sandbox failure (attempts to write to /var/lib/rpm)
diff --git a/dev-lang/python/python-3.11.0_alpha2.ebuild b/dev-lang/python/python-3.11.0_alpha2.ebuild
index af6ab1080186..feb574f7b6ce 100644
--- a/dev-lang/python/python-3.11.0_alpha2.ebuild
+++ b/dev-lang/python/python-3.11.0_alpha2.ebuild
@@ -163,7 +163,12 @@ src_configure() {
if use pgo; then
local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
- export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb"
+ export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb -u-network"
+
+ # All of these seem to occasionally hang for PGO inconsistently
+ # They'll even hang here but be fine in src_test sometimes.
+ # bug #828535 (and related: bug #788022)
+ PROFILE_TASK+=" -x test_socket -x test_asyncio -x test_httpservers -x test_logging -x test_multiprocessing_fork -x test_xmlrpc"
if has_version "app-arch/rpm" ; then
# Avoid sandbox failure (attempts to write to /var/lib/rpm)
diff --git a/dev-lang/python/python-3.9.9.ebuild b/dev-lang/python/python-3.9.9.ebuild
index b98774878ab2..a80090cacc42 100644
--- a/dev-lang/python/python-3.9.9.ebuild
+++ b/dev-lang/python/python-3.9.9.ebuild
@@ -160,7 +160,12 @@ src_configure() {
if use pgo; then
local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
- export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb"
+ export PROFILE_TASK="-m test -j${jobs} --pgo-extended -x test_gdb -u-network"
+
+ # All of these seem to occasionally hang for PGO inconsistently
+ # They'll even hang here but be fine in src_test sometimes.
+ # bug #828535 (and related: bug #788022)
+ PROFILE_TASK+=" -x test_socket -x test_asyncio -x test_httpservers -x test_logging -x test_multiprocessing_fork -x test_xmlrpc"
if has_version "app-arch/rpm" ; then
# Avoid sandbox failure (attempts to write to /var/lib/rpm)