summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-24 16:00:00 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-24 16:00:53 -0700
commite2ff60b95ccb191913fd0156c64a3555d3b7c976 (patch)
tree4ba7482b49a1c828cc3f52886de3bbe52acaca62 /dev-lang
parentdev-lang/rust-bin: add rls useflag to 1.45.2 (diff)
downloadgentoo-e2ff60b95ccb191913fd0156c64a3555d3b7c976.tar.gz
gentoo-e2ff60b95ccb191913fd0156c64a3555d3b7c976.tar.bz2
gentoo-e2ff60b95ccb191913fd0156c64a3555d3b7c976.zip
dev-lang/rust-bin: backport rls flag to 1.44.1
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.44.1.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.44.1.ebuild b/dev-lang/rust-bin/rust-bin-1.44.1.ebuild
index 0ac82e0b3a12..7165b90fd15d 100644
--- a/dev-lang/rust-bin/rust-bin-1.44.1.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.44.1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="$(rust_all_arch_uris ${MY_P})"
LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="stable"
KEYWORDS="amd64 arm arm64 ppc64 x86"
-IUSE="clippy cpu_flags_x86_sse2 doc rustfmt"
+IUSE="clippy cpu_flags_x86_sse2 doc rls rustfmt"
DEPEND=""
RDEPEND=">=app-eselect/eselect-rust-20190311"
@@ -50,7 +50,8 @@ multilib_src_install() {
local components="rustc,cargo,${std}"
use doc && components="${components},rust-docs"
use clippy && components="${components},clippy-preview"
- use rustfmt && components="${components},rustfmt-preview"
+ use rls && components="${components},rls-preview"
+ use rustfmt && components="${components},rustfmt-preview,rust-analysis"
./install.sh \
--components="${components}" \
--disable-verify \
@@ -98,6 +99,13 @@ multilib_src_install() {
dosym "../../opt/${P}/bin/${clippy_driver}" "/usr/bin/${clippy_driver}"
dosym "../../opt/${P}/bin/${cargo_clippy}" "/usr/bin/${cargo_clippy}"
fi
+ if use rls; then
+ local rls=rls-bin-${PV}
+ mv "${ED}/opt/${P}/bin/rls" "${ED}/opt/${P}/bin/${rls}" || die
+
+ dosym "${rls}" "/opt/${P}/bin/rls"
+ dosym "../../opt/${P}/bin/${rls}" "/usr/bin/${rls}"
+ fi
if use rustfmt; then
local rustfmt=rustfmt-bin-${PV}
local cargo_fmt=cargo-fmt-bin-${PV}
@@ -127,6 +135,9 @@ multilib_src_install() {
echo /usr/bin/clippy-driver >> "${T}/provider-${P}"
echo /usr/bin/cargo-clippy >> "${T}/provider-${P}"
fi
+ if use rls; then
+ echo /usr/bin/rls >> "${T}/provider-${P}"
+ fi
if use rustfmt; then
echo /usr/bin/rustfmt >> "${T}/provider-${P}"
echo /usr/bin/cargo-fmt >> "${T}/provider-${P}"