summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-08-30 22:39:11 +0300
committerMart Raudsepp <leio@gentoo.org>2018-08-30 23:50:14 +0300
commit07ada1db9106b2d18fa178a0a070c74aa6b88b36 (patch)
treea0e1bbff137b4e3f0e04ef90940872319545c540 /dev-libs/atk
parentapp-crypt/ccid: cleanup old (diff)
downloadgentoo-07ada1db9106b2d18fa178a0a070c74aa6b88b36.tar.gz
gentoo-07ada1db9106b2d18fa178a0a070c74aa6b88b36.tar.bz2
gentoo-07ada1db9106b2d18fa178a0a070c74aa6b88b36.zip
dev-libs/atk: bump to 2.28.1
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'dev-libs/atk')
-rw-r--r--dev-libs/atk/Manifest1
-rw-r--r--dev-libs/atk/atk-2.28.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-libs/atk/Manifest b/dev-libs/atk/Manifest
index d0d6cace5214..84f17d6bbfc3 100644
--- a/dev-libs/atk/Manifest
+++ b/dev-libs/atk/Manifest
@@ -1,2 +1,3 @@
DIST atk-2.22.0.tar.xz 745572 BLAKE2B 4764a6044446de8e08b54c47400727268ca68e676aa36c01877f2b3f973614a40f209406b649f0e96f4a5b75be883ce67ac3fbf20ac0c58adfbaf3509caac312 SHA512 af3f6197eb97de869ee706f19564449b02c1444c413e5418323e4bf4c8cf1d98c7c8baa25189f6879d63606d4bc75f33799cb901f4697c087e868bb9a5643cba
DIST atk-2.24.0.tar.xz 748972 BLAKE2B f9db7e35322cf4a1df5171c812c83eb935ba44b0167b20ca9a951109c00911392a48db88fac02a12074de4d9f458656f946e8bb7611e1d11cc0de841986f8cc7 SHA512 3ae0a4d5f28d5619d465135c685161f690732053bcb70a47669c951fbf389b5d2ccc5c7c73d4ee8c5a3b2df14e2f5b082e812a215f10a79b27b412d077f5e962
+DIST atk-2.28.1.tar.xz 712508 BLAKE2B 71aee8bc937e1e37d40e6a9820d0002bcc763dbf87385ede2484ec6fe17a9924d5753d74dc3a769602746c915d0c46da8eea78cc80c706e3c38faca2e5050364 SHA512 aa61e7718b3f4d9c33ec2b4747e35f894a51550ef39ecc4a7af5705811c029645bd3c728071f446b075a0b7aef0c35c1b73406a210cd30171838f24a8dfc0abb
diff --git a/dev-libs/atk/atk-2.28.1.ebuild b/dev-libs/atk/atk-2.28.1.ebuild
new file mode 100644
index 000000000000..00caaa9ac80f
--- /dev/null
+++ b/dev-libs/atk/atk-2.28.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="GTK+ & GNOME Accessibility Toolkit"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="+introspection nls test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.32.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ nls? ( >=sys-devel/gettext-0.19.2 )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests (bug #226353)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Building out of sources fails, https://bugzilla.gnome.org/show_bug.cgi?id=752507
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+# ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection)
+
+ # work-around gtk-doc out-of-source brokedness
+# if multilib_is_native_abi; then
+# ln -s "${S}"/docs/html docs/html || die
+# fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}