summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-06-23 06:52:23 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-07-15 18:58:17 +0200
commit4ff9c10ea72790d1d7b2dd8c2c65d42cd10f238a (patch)
tree61599f93451b852ca05d2ae618881eac3684118d /dev-libs/clipper/clipper-6.4.2.ebuild
parentdev-ros/qt_dotgraph: Remove old (diff)
downloadgentoo-4ff9c10ea72790d1d7b2dd8c2c65d42cd10f238a.tar.gz
gentoo-4ff9c10ea72790d1d7b2dd8c2c65d42cd10f238a.tar.bz2
gentoo-4ff9c10ea72790d1d7b2dd8c2c65d42cd10f238a.zip
dev-libs/clipper: added new ebuild
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-libs/clipper/clipper-6.4.2.ebuild')
-rw-r--r--dev-libs/clipper/clipper-6.4.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/clipper/clipper-6.4.2.ebuild b/dev-libs/clipper/clipper-6.4.2.ebuild
new file mode 100644
index 000000000000..cc85916233e0
--- /dev/null
+++ b/dev-libs/clipper/clipper-6.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit cmake
+
+MY_PV="ver${PV}"
+MY_P="${PN}_${MY_PV}"
+
+DESCRIPTION="Polygon and line clipping and offsetting library (C++, C#, Delphi)"
+HOMEPAGE="http://www.angusj.com/delphi/clipper.php"
+SRC_URI="mirror://sourceforge/project/polyclipping/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND=""
+BDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/cpp"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ )
+ cmake_src_configure
+} \ No newline at end of file