summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/distorm64
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/distorm64')
-rw-r--r--dev-libs/distorm64/Manifest3
-rw-r--r--dev-libs/distorm64/distorm64-1.7.30-r1.ebuild70
-rw-r--r--dev-libs/distorm64/distorm64-3.1.ebuild33
-rw-r--r--dev-libs/distorm64/distorm64-3.3-r1.ebuild27
-rw-r--r--dev-libs/distorm64/distorm64-3.3.ebuild36
-rw-r--r--dev-libs/distorm64/files/distorm64-1.7.30-python.patch11
-rw-r--r--dev-libs/distorm64/files/distorm64-1.7.30-respect_flags.patch42
-rw-r--r--dev-libs/distorm64/metadata.xml21
8 files changed, 243 insertions, 0 deletions
diff --git a/dev-libs/distorm64/Manifest b/dev-libs/distorm64/Manifest
new file mode 100644
index 000000000000..56c8c10a44ca
--- /dev/null
+++ b/dev-libs/distorm64/Manifest
@@ -0,0 +1,3 @@
+DIST distorm3-1.0.zip 137505 SHA256 f381d0ddabed04ee9161633d3eb3c0bdb87100accd9b669385d4d72b36931f69 SHA512 56e9640b8f140ab9cf9cbacd205b7caf21a84ad698c1b1b3cf93194c986e4de107e056929742301ee7491c5e9bf75784d712740a2fadec084952ca5382fb7e24 WHIRLPOOL 95d4b4fa4a31c6f7fa101fd2f807c89eb87ff6d1a5cb150e14198e655c54acb77caf13a7ad12ba0abea59e0be17f6ca6d04bd0a70c572bd807d436013c4bbaf3
+DIST distorm3-3-sdist.zip 143096 SHA256 a4794af34bc71b1efebf155ff046b236af6b218c11c01127e63bdca340d43abe SHA512 a00a24af997d22c905ba7a311c7f7a4345458888163225266bf3f7f8449b12fa7089ad9154cbfa65ed2f9ffe1002b4475de812778792250bd714cb69c41f5eb9 WHIRLPOOL bd2226394ed25fac93876ae5c7a0f5a073fccb056aa4e9b9bcdd06b2f9414954a0e4c5b94ca254637f648177282fe928f54f16368fd28dab644fe27c1c9f87e7
+DIST distorm64-pkg1.7.30.tar.bz2 91976 SHA256 bc2fc90e2111dfbba7fa397725ed6ae8b70477a3f7c60995e73d44a778a751be SHA512 d5890a3c295a81d6b59eabc14bbf2cdb8686f7675bae993ab2ec7a4d6957ab3a700776c75e58443db78c6cb29b9aaa287d4eac6c35bec68d444d3dbd5fba03c8 WHIRLPOOL 1f8c0f4bcf54ad1cb0b5460c11e031711d6c1d3db60b3c003d2d2ace1dae3c2b92f4e93ca20d119ffc34a41f6c902b1970229038b4e2518e20f18d980cc29082
diff --git a/dev-libs/distorm64/distorm64-1.7.30-r1.ebuild b/dev-libs/distorm64/distorm64-1.7.30-r1.ebuild
new file mode 100644
index 000000000000..b64a51de726c
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-1.7.30-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils flag-o-matic python toolchain-funcs
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+SRC_URI="http://ragestorm.net/distorm/${PN}-pkg${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+python"
+
+DEPEND="python? ( >=dev-lang/python-2.4 )"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python.patch"
+ epatch "${FILESDIR}/${P}-respect_flags.patch"
+}
+
+src_compile() {
+ cd "${WORKDIR}/${PN}/build/linux"
+ emake CC="$(tc-getCC)" clib || die "emake clib failed"
+
+ if use python; then
+ building() {
+ # Build ../../src/pydistorm.o separately with each enabled version of Python.
+ rm -f ../../src/pydistorm.o
+
+ # Additional CFLAGS retrieved from build/linux/Makefile.
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -I$(python_get_includedir) -Wall -fPIC -DSUPPORT_64BIT_OFFSET -D_DLL" TARGET="distorm.so-${PYTHON_ABI}" py
+ }
+ python_execute_function building
+ fi
+
+ cd "${WORKDIR}/${PN}/linuxproj"
+ emake CC="$(tc-getCC)" disasm || die "emake disasm failed"
+
+}
+
+src_install() {
+ cd "${WORKDIR}/${PN}/build/linux"
+
+ dolib.so libdistorm64.so
+
+ if use python; then
+ installation() {
+ dodir "$(python_get_sitedir)"
+ install distorm.so-${PYTHON_ABI} "${D}$(python_get_sitedir)/distorm.so"
+ }
+ python_execute_function -q installation
+ fi
+
+ cd "${WORKDIR}/${PN}"
+ newlib.a distorm64.a libdistorm64.a
+
+ dobin linuxproj/disasm
+
+ dodir "/usr/include"
+ install distorm.h "${D}usr/include/" || die "Unable to install distorm.h"
+}
diff --git a/dev-libs/distorm64/distorm64-3.1.ebuild b/dev-libs/distorm64/distorm64-3.1.ebuild
new file mode 100644
index 000000000000..3c89fcfb6e8c
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.5"
+
+inherit eutils distutils python
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+# This is not nice - hardcoding is bad
+SRC_URI="http://distorm.googlecode.com/files/distorm3-1.0.zip"
+S="${WORKDIR}/distorm3-1.0"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+pkg_setup() {
+ python_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+}
diff --git a/dev-libs/distorm64/distorm64-3.3-r1.ebuild b/dev-libs/distorm64/distorm64-3.3-r1.ebuild
new file mode 100644
index 000000000000..e4ed572c7e3c
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-3.3-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+MY_PN=distorm
+MY_PV=$(replace_all_version_separators '-')
+MY_P=${MY_PN}${MY_PV}
+
+SRC_URI="http://distorm.googlecode.com/files/${MY_P}-sdist.zip"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/dev-libs/distorm64/distorm64-3.3.ebuild b/dev-libs/distorm64/distorm64-3.3.ebuild
new file mode 100644
index 000000000000..61bd7aa8bf76
--- /dev/null
+++ b/dev-libs/distorm64/distorm64-3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.5"
+
+inherit eutils distutils python versionator
+
+DESCRIPTION="The ultimate disassembler library (X86-32, X86-64)"
+HOMEPAGE="http://www.ragestorm.net/distorm/"
+
+MY_PN=distorm
+MY_PV=$(replace_all_version_separators '-')
+MY_P=${MY_PN}${MY_PV}
+
+SRC_URI="http://distorm.googlecode.com/files/${MY_P}-sdist.zip"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+pkg_setup() {
+ python_pkg_setup
+}
+
+src_compile() {
+ distutils_src_compile
+}
diff --git a/dev-libs/distorm64/files/distorm64-1.7.30-python.patch b/dev-libs/distorm64/files/distorm64-1.7.30-python.patch
new file mode 100644
index 000000000000..15d82f2215d7
--- /dev/null
+++ b/dev-libs/distorm64/files/distorm64-1.7.30-python.patch
@@ -0,0 +1,11 @@
+--- src/pydistorm.h
++++ src/pydistorm.h
+@@ -22,7 +22,7 @@
+ #include "decoder.h"
+
+ #ifdef __GNUC__
+- #include <python2.5/Python.h>
++ #include <Python.h>
+ #elif _MSC_VER
+ #include <python.h>
+ #endif
diff --git a/dev-libs/distorm64/files/distorm64-1.7.30-respect_flags.patch b/dev-libs/distorm64/files/distorm64-1.7.30-respect_flags.patch
new file mode 100644
index 000000000000..0af2da2f7a9b
--- /dev/null
+++ b/dev-libs/distorm64/files/distorm64-1.7.30-respect_flags.patch
@@ -0,0 +1,42 @@
+--- build/linux/Makefile
++++ build/linux/Makefile
+@@ -6,7 +6,7 @@
+ COBJS = ../../src/x86defs.o ../../src/wstring.o ../../src/textdefs.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/distorm.o ../../src/decoder.o
+ PYOBJS = ../../src/x86defs.o ../../src/wstring.o ../../src/textdefs.o ../../src/pydistorm.o ../../src/prefix.o ../../src/operands.o ../../src/insts.o ../../src/instructions.o ../../src/decoder.o
+ CC = gcc
+-CFLAGS = -O2 -Wall -fPIC -DSUPPORT_64BIT_OFFSET -D_DLL
++CFLAGS += -Wall -fPIC -DSUPPORT_64BIT_OFFSET -D_DLL
+
+ all: clib py
+
+@@ -14,11 +14,11 @@
+ /bin/rm -rf ../../src/*.o ${TARGET} ../../distorm64.a
+
+ clib: ${COBJS}
+- ${CC} ${CFLAGS} ${VERSION} ${COBJS} -fPIC -shared -o ${TARGET}
++ ${CC} ${LDFLAGS} ${VERSION} ${COBJS} -fPIC -shared -o ${TARGET}
+ ar rs ../../distorm64.a ${COBJS}
+
+ py: ${PYOBJS}
+- ${CC} ${CFLAGS} ${VERSION} ${PYOBJS} -fPIC -shared -o ${TARGET}
++ ${CC} ${LDFLAGS} ${VERSION} ${PYOBJS} -fPIC -shared -o ${TARGET}
+
+ install: libdistorm64.so
+ install -s ${TARGET} /usr/local/lib
+--- linuxproj/Makefile
++++ linuxproj/Makefile
+@@ -4,12 +4,12 @@
+
+ TARGET = disasm
+ CC = gcc
+-CFLAGS = -Wall -O2 -I. -o
++CFLAGS += -Wall -I.
+
+ all: disasm
+
+ disasm:
+- ${CC} ${CFLAGS} ${TARGET} main.c ../distorm64.a
++ ${CC} ${CFLAGS} ${LDFLAGS} -o ${TARGET} main.c ../distorm64.a
+
+ clean:
+ /bin/rm -rf *.o ${TARGET}
diff --git a/dev-libs/distorm64/metadata.xml b/dev-libs/distorm64/metadata.xml
new file mode 100644
index 000000000000..c1b4579d865e
--- /dev/null
+++ b/dev-libs/distorm64/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ <description>Maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>ikelos@gentoo.org</email>
+ <name>Mike Auty</name>
+ <description>Maintainer</description>
+ </maintainer>
+ <maintainer>
+ <email>slyfox@gentoo.org</email>
+ <name>Sergei Trofimovich</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">distorm</remote-id>
+ </upstream>
+</pkgmetadata>