summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-02-09 00:57:57 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-02-09 00:58:14 +0100
commitb4492759eb4e4d96bcaa145d21a1c2f06dc27c4b (patch)
tree56b5bc32d0db7303c7349914e01dd31cc66f751d /dev-libs/liborcus
parentdev-util/mdds: Fix subslot in live ebuild (diff)
downloadgentoo-b4492759eb4e4d96bcaa145d21a1c2f06dc27c4b.tar.gz
gentoo-b4492759eb4e4d96bcaa145d21a1c2f06dc27c4b.tar.bz2
gentoo-b4492759eb4e4d96bcaa145d21a1c2f06dc27c4b.zip
dev-libs/liborcus: Untested bump, work in progress
Closes: https://bugs.gentoo.org/830457 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-libs/liborcus')
-rw-r--r--dev-libs/liborcus/Manifest1
-rw-r--r--dev-libs/liborcus/liborcus-0.17.2.ebuild67
-rw-r--r--dev-libs/liborcus/liborcus-9999.ebuild18
3 files changed, 79 insertions, 7 deletions
diff --git a/dev-libs/liborcus/Manifest b/dev-libs/liborcus/Manifest
index 2f82c613714c..8ab89e05f2d6 100644
--- a/dev-libs/liborcus/Manifest
+++ b/dev-libs/liborcus/Manifest
@@ -1,2 +1,3 @@
DIST liborcus-0.16.1.tar.xz 1805436 BLAKE2B 7df89da5a175daa6fcf759d28f8a0eaebf3db6405af3b06a01b8dad41c7706acedc74876a0b68ff9cabd5780bb7cb311cd7c98390c9ecd265e62513eadde81eb SHA512 6d75591820af65181dd3a418f051a359695083f29c7d9c77edbcab3e89d9ea367824be0b19f27a31267525f446936145f5780a0ce3c6ee2d89823742837d4739
DIST liborcus-0.17.0.tar.xz 1826696 BLAKE2B 4cab8696f698510de6c995aa6a3e59a8407297d6a60bac89ca7ffa1f74576de555c69a38de97eac63e2aed1817a3377ec7e15b1da7b5c01b49d049092d8756ff SHA512 1ac24f3c10973d0e0f6e3db7982391434631ec998ae07bb011fa8e000e48ca430c07a0c2588871a93b6d9bf7a19e30d4f05d34aef699dfce1f59a4556c7727e8
+DIST liborcus-0.17.2.tar.xz 1839188 BLAKE2B d274e3af71df16866e305403d63d3978613915753412ac9de19d7de7802930c3886d8653d6d48a8d9a971dc0ee284f8f83af8dc07850b5f28fcdab2815b6d9b2 SHA512 8ad8db46c23673260057aff555286d95ebfeff0a027bdeae24f11f8aa12456284f7f4446edddb91936b3011eb1227cfe1618ab3c4d909f8356c8c151f5739d79
diff --git a/dev-libs/liborcus/liborcus-0.17.2.ebuild b/dev-libs/liborcus/liborcus-0.17.2.ebuild
new file mode 100644
index 000000000000..16b12b9e36fa
--- /dev/null
+++ b/dev-libs/liborcus/liborcus-0.17.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="Standalone file import filter library for spreadsheet documents"
+HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
+
+if [[ ${PV} == *9999* ]]; then
+ MDDS_SLOT="1/2.0"
+ EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
+ inherit git-r3
+else
+ MDDS_SLOT="1/2.0"
+ SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
+ # Unkeyworded while libreoffice has no release making use of this slot
+ # KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/0.17" # based on SONAME of liborcus.so
+IUSE="python +spreadsheet-model test tools"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost:=[zlib(+)]
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+ spreadsheet-model? ( dev-libs/libixion:${SLOT} )
+"
+DEPEND="${RDEPEND}
+ dev-util/mdds:${MDDS_SLOT}
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # bug 713586
+ use test && eapply "${FILESDIR}/${P}-test-fix.patch"
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --disable-werror
+ $(use_enable python)
+ $(use_enable spreadsheet-model)
+ $(use_with tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}
diff --git a/dev-libs/liborcus/liborcus-9999.ebuild b/dev-libs/liborcus/liborcus-9999.ebuild
index b923d9595f82..16b12b9e36fa 100644
--- a/dev-libs/liborcus/liborcus-9999.ebuild
+++ b/dev-libs/liborcus/liborcus-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8,9,10} )
inherit autotools python-single-r1
@@ -11,20 +11,22 @@ DESCRIPTION="Standalone file import filter library for spreadsheet documents"
HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
if [[ ${PV} == *9999* ]]; then
- MDDS_SLOT="1/9999"
+ MDDS_SLOT="1/2.0"
EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
inherit git-r3
else
- MDDS_SLOT="1/1.5"
+ MDDS_SLOT="1/2.0"
SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ # Unkeyworded while libreoffice has no release making use of this slot
+ # KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
fi
LICENSE="MIT"
SLOT="0/0.17" # based on SONAME of liborcus.so
-IUSE="python +spreadsheet-model tools"
+IUSE="python +spreadsheet-model test tools"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-libs/boost:=[zlib(+)]
@@ -41,6 +43,9 @@ pkg_setup() {
}
src_prepare() {
+ # bug 713586
+ use test && eapply "${FILESDIR}/${P}-test-fix.patch"
+
default
eautoreconf
}
@@ -59,5 +64,4 @@ src_configure() {
src_install() {
default
find "${D}" -name '*.la' -type f -delete || die
- use python && python_optimize
}