summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2021-09-02 13:35:13 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-09-04 09:05:01 +0300
commit95b07883ea66954424ef4bbc5b94cbbff9f6913c (patch)
treedede565316171b782c46d0aa580c3e224bb05c89 /dev-libs/libtpms
parentsci-geosciences/josm-bin: add missing BDEPEND="app-arch/unzip" (diff)
downloadgentoo-95b07883ea66954424ef4bbc5b94cbbff9f6913c.tar.gz
gentoo-95b07883ea66954424ef4bbc5b94cbbff9f6913c.tar.bz2
gentoo-95b07883ea66954424ef4bbc5b94cbbff9f6913c.zip
dev-libs/libtpms: Bump to 0.8.5
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/libtpms')
-rw-r--r--dev-libs/libtpms/Manifest1
-rw-r--r--dev-libs/libtpms/libtpms-0.8.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libtpms/Manifest b/dev-libs/libtpms/Manifest
index 06243131e7de..dcf7baba26f4 100644
--- a/dev-libs/libtpms/Manifest
+++ b/dev-libs/libtpms/Manifest
@@ -1,2 +1,3 @@
DIST libtpms-0.8.3.tar.gz 1254474 BLAKE2B c71f52d6475d4328e93a35f88557de3400308984ec086f7e6b3c32ebc266e078b3a9864396546ba11fc310c1572efa1521bdac89075c5eba18cb35eef883e706 SHA512 07cf78c2a5b03f3c9179b041db57d5ec049dc0085c09e4fd5c9b54a247cf81a3b9982f0fb1cd571cd6b21b3d9824b061f8f38508fc25b6a23a6a6b06dea7115b
DIST libtpms-0.8.4.tar.gz 1255255 BLAKE2B 0786b19dc8f3226508548ab16544ee8ac05e8d9de057eed840a0cb7577c1d1386d83af1a725ec91e64344e2459f9d4836268e2c9a097136cf76d59ea8e23b0c8 SHA512 58244a774cb6ec5dcbbc2d795628fca9eb64936874c72b169ea8288f2bf0cafa8127b1e89ed3ddbf5694df5a5944a7d61254dc729d75b63b3e4f9346b2f0a7b5
+DIST libtpms-0.8.5.tar.gz 1255741 BLAKE2B a9960d4f58093f9291ee718c4577138cfd36f637a2911b2bacc3dde68b9def5ab1fd085e38a46b8a57d15f68072e7268a132687f5cc8c593390b1ef986aa0813 SHA512 7f1591b6b655ec99d3737ee41e37e4c0fc05f2e9676463a44c88015b37b2a39291a576e81e394cdf3deac3f1227774c6c60baca445befb24339515773e20b766
diff --git a/dev-libs/libtpms/libtpms-0.8.5.ebuild b/dev-libs/libtpms/libtpms-0.8.5.ebuild
new file mode 100644
index 000000000000..72093b562970
--- /dev/null
+++ b/dev-libs/libtpms/libtpms-0.8.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library providing software emultion of a TPM"
+HOMEPAGE="https://github.com/stefanberger/libtpms"
+SRC_URI="https://github.com/stefanberger/libtpms/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64"
+
+DEPEND="dev-libs/openssl:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.8.0-Remove-WError.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --with-openssl \
+ --with-tpm2
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 0.8.0; then
+ elog "Versions of libtpms prior to 0.8.0 generate weaker than expected TPM 2.0 RSA"
+ elog "keys due to a flawed key creation algorithm. Because fixing this would render"
+ elog "existing sealed data inaccessible, to use the corrected algorithm, the old"
+ elog "TPM state file must be deleted and a new TPM state file created. Data still"
+ elog "sealed using the old state file will be permanently inaccessible. For the"
+ elog "details see https://github.com/stefanberger/libtpms/issues/183"
+ fi
+}