summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2021-10-03 00:37:58 +0200
committerSam James <sam@gentoo.org>2021-10-18 05:10:23 +0100
commitdb02aa38b2c766f454b31c9d051f3729c4e398df (patch)
tree8406bef48405aeacb2f786aa7900c9ad5f18f119 /dev-libs/libuev/files
parentapp-emulation/slirp4netns: Bump to version 1.1.12 (diff)
downloadgentoo-db02aa38b2c766f454b31c9d051f3729c4e398df.tar.gz
gentoo-db02aa38b2c766f454b31c9d051f3729c4e398df.tar.bz2
gentoo-db02aa38b2c766f454b31c9d051f3729c4e398df.zip
dev-libs/libuev: fix building with sys-libs/glibc-2.34
Closes: https://bugs.gentoo.org/806604 Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libuev/files')
-rw-r--r--dev-libs/libuev/files/libuev-64-bit-times.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libuev/files/libuev-64-bit-times.patch b/dev-libs/libuev/files/libuev-64-bit-times.patch
new file mode 100644
index 000000000000..b018da1ef704
--- /dev/null
+++ b/dev-libs/libuev/files/libuev-64-bit-times.patch
@@ -0,0 +1,32 @@
+diff --git a/configure.ac b/configure.ac
+index 786f502..c9859b1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,4 +1,4 @@
+-AC_INIT(libuev, 2.4.0-beta1, https://github.com/troglobit/libuev/issues)
++AC_INIT(libuev, 2.4.0-rc1, https://github.com/troglobit/libuev/issues)
+ AC_CONFIG_AUX_DIR(aux)
+ AM_INIT_AUTOMAKE([1.11 foreign dist-xz])
+ AM_SILENT_RULES([yes])
+diff --git a/src/libuev.pc.in b/src/libuev.pc.in
+index 9f831a6..4b00176 100644
+--- a/src/libuev.pc.in
++++ b/src/libuev.pc.in
+@@ -8,5 +8,5 @@ Description: Simple event loop for Linux
+ Version: @VERSION@
+ Requires:
+ Libs: -L${libdir} -luev
+-Cflags: -I${includedir}
++Cflags: -I${includedir} -D_TIME_BITS=64 -D_FILE_OFFSET_BITS=64
+
+diff --git a/test/Makefile.am b/test/Makefile.am
+index 72fdfb4..6bbfc85 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -12,5 +12,5 @@ TESTS += event
+
+ check_PROGRAMS = $(TESTS)
+
+-CPPFLAGS = -D_GNU_SOURCE
++CPPFLAGS = -D_GNU_SOURCE -D_TIME_BITS=64 -D_FILE_OFFSET_BITS=64
+ LDADD = -L../src ../src/libuev.la