summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-13 10:48:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-13 10:48:41 +0200
commit7cebb96c65a9755ed9d748b61300f44ba41780bf (patch)
tree2b004c7c33ae1e0ae96d4ea9fb849e242a5cbcbf /dev-libs/serd/serd-0.22.0.ebuild
parentdev-libs/sord: Bump to 0.14.0 (diff)
downloadgentoo-7cebb96c65a9755ed9d748b61300f44ba41780bf.tar.gz
gentoo-7cebb96c65a9755ed9d748b61300f44ba41780bf.tar.bz2
gentoo-7cebb96c65a9755ed9d748b61300f44ba41780bf.zip
dev-libs/serd: Bump to 0.22.0
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-libs/serd/serd-0.22.0.ebuild')
-rw-r--r--dev-libs/serd/serd-0.22.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/serd/serd-0.22.0.ebuild b/dev-libs/serd/serd-0.22.0.ebuild
new file mode 100644
index 000000000000..f8b9d1df228d
--- /dev/null
+++ b/dev-libs/serd/serd-0.22.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="Library for RDF syntax which supports reading and writing Turtle and NTriples"
+HOMEPAGE="http://drobilla.net/software/serd/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_prepare() {
+ sed -i -e 's/^.*run_ldconfig/#\0/' wscript || die
+}
+
+src_configure() {
+ waf-utils_src_configure \
+ --docdir=/usr/share/doc/${PF} \
+ $(use test && echo "--test") \
+ $(use doc && echo "--docs") \
+ $(use static-libs && echo "--static")
+}
+
+src_test() {
+ ./waf test || die
+}