summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2023-03-29 23:48:27 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-04-18 09:03:25 +0300
commit00e0db67f29624099ac46fba940246c65a0c9b71 (patch)
tree72cd1fffff4c17432e9d53b6f0feb5385b356a36 /dev-libs
parentdev-qt/qtscxml: add 6.5.0 (diff)
downloadgentoo-00e0db67f29624099ac46fba940246c65a0c9b71.tar.gz
gentoo-00e0db67f29624099ac46fba940246c65a0c9b71.tar.bz2
gentoo-00e0db67f29624099ac46fba940246c65a0c9b71.zip
dev-libs/qhotkey: new package, v1.5.0
A global shortcut/hotkey library for desktop Qt applications. Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/qhotkey/Manifest1
-rw-r--r--dev-libs/qhotkey/metadata.xml18
-rw-r--r--dev-libs/qhotkey/qhotkey-1.5.0.ebuild36
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-libs/qhotkey/Manifest b/dev-libs/qhotkey/Manifest
new file mode 100644
index 000000000000..627b3a927533
--- /dev/null
+++ b/dev-libs/qhotkey/Manifest
@@ -0,0 +1 @@
+DIST qhotkey-1.5.0.tar.gz 53083 BLAKE2B fab832d97ea8525b6d2916543b60c4e9ec2af1e0461b402d22367f5a9654b564cc24ee835e2157b1ef9f2dece66b750105b9815ccd7e0db4ae7352b33a5d6750 SHA512 c57135864e976c0881bca320f39ff98ec6973cb226902fe051b844ad29d106593bdf5524335b8f83a62cecac362af95b61964bc5fa6a47abcb7adf668bcc14c1
diff --git a/dev-libs/qhotkey/metadata.xml b/dev-libs/qhotkey/metadata.xml
new file mode 100644
index 000000000000..884dd3b49960
--- /dev/null
+++ b/dev-libs/qhotkey/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>gentoo@retornaz.com</email>
+ <name>Quentin Retornaz</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Skycoder42/QHotkey</remote-id>
+ </upstream>
+ <use>
+ <flag name="qt6">Use Qt6 dependencies</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-libs/qhotkey/qhotkey-1.5.0.ebuild b/dev-libs/qhotkey/qhotkey-1.5.0.ebuild
new file mode 100644
index 000000000000..5721563f8374
--- /dev/null
+++ b/dev-libs/qhotkey/qhotkey-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A global shortcut/hotkey library for desktop Qt applications"
+HOMEPAGE="https://github.com/Skycoder42/QHotkey"
+
+MY_PN="QHotkey"
+
+SRC_URI="https://github.com/Skycoder42/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="qt6"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DEPEND="
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtx11extras:5
+ )
+ qt6? (
+ dev-qt/qtbase:6
+ )
+ x11-libs/libX11
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_DEFAULT_MAJOR_VERSION:STRING=$(usex qt6 "6" "5")
+ )
+ cmake_src_configure
+}