summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-29 11:53:17 +0100
committerSam James <sam@gentoo.org>2024-06-29 11:53:17 +0100
commit735129368d5173d2b41df50a7951ca988c22a274 (patch)
treefdf4b5ae8b63816ff5ec80812e47fbf1edc76fd8 /dev-lisp
parentdev-lisp/gcl: filter LTO for GCC bug (diff)
downloadgentoo-735129368d5173d2b41df50a7951ca988c22a274.tar.gz
gentoo-735129368d5173d2b41df50a7951ca988c22a274.tar.bz2
gentoo-735129368d5173d2b41df50a7951ca988c22a274.zip
dev-lisp/ecl: filter LTO for GCC bug
The code is pretty brittle anyway. Bug: https://gcc.gnu.org/PR114919 Bug: https://bugs.gentoo.org/931081 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecl/ecl-21.2.1-r5.ebuild6
-rw-r--r--dev-lisp/ecl/ecl-23.9.9-r1.ebuild4
-rw-r--r--dev-lisp/ecl/ecl-24.5.10.ebuild4
3 files changed, 10 insertions, 4 deletions
diff --git a/dev-lisp/ecl/ecl-21.2.1-r5.ebuild b/dev-lisp/ecl/ecl-21.2.1-r5.ebuild
index a12f59e6b270..3d735305d8a2 100644
--- a/dev-lisp/ecl/ecl-21.2.1-r5.ebuild
+++ b/dev-lisp/ecl/ecl-21.2.1-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit readme.gentoo-r1
+inherit flag-o-matic readme.gentoo-r1
DESCRIPTION="ECL is an embeddable Common Lisp implementation"
HOMEPAGE="https://common-lisp.net/project/ecl/"
@@ -40,6 +40,8 @@ src_prepare() {
}
src_configure() {
+ filter-lto # bug #931081
+
econf \
--enable-gmp=system \
--enable-boehm=system \
diff --git a/dev-lisp/ecl/ecl-23.9.9-r1.ebuild b/dev-lisp/ecl/ecl-23.9.9-r1.ebuild
index 542b691a6db0..ba0b9418f3ee 100644
--- a/dev-lisp/ecl/ecl-23.9.9-r1.ebuild
+++ b/dev-lisp/ecl/ecl-23.9.9-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit readme.gentoo-r1
+inherit flag-o-matic readme.gentoo-r1
DESCRIPTION="ECL is an embeddable Common Lisp implementation"
HOMEPAGE="https://common-lisp.net/project/ecl/"
@@ -39,6 +39,8 @@ src_prepare() {
}
src_configure() {
+ filter-lto # bug #931081
+
econf \
--enable-gmp=system \
--enable-boehm=system \
diff --git a/dev-lisp/ecl/ecl-24.5.10.ebuild b/dev-lisp/ecl/ecl-24.5.10.ebuild
index 07b7369d78df..c289fe3b035d 100644
--- a/dev-lisp/ecl/ecl-24.5.10.ebuild
+++ b/dev-lisp/ecl/ecl-24.5.10.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit readme.gentoo-r1
+inherit flag-o-matic readme.gentoo-r1
DESCRIPTION="ECL is an embeddable Common Lisp implementation"
HOMEPAGE="https://common-lisp.net/project/ecl/"
@@ -39,6 +39,8 @@ src_prepare() {
}
src_configure() {
+ filter-lto # bug #931081
+
econf \
--enable-gmp=system \
--enable-boehm=system \