summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-11-11 08:34:50 -0600
committerWilliam Hubbs <williamh@gentoo.org>2015-11-11 11:39:48 -0600
commitba3d52d5539e87de62ff1bdfd7423fd758cd5431 (patch)
tree165048e49e3ebf4e23d95389eaed092a8dfe0d75 /dev-lua/lua-term/lua-term-0.3.ebuild
parentdev-lua/penlight: initial commit (diff)
downloadgentoo-ba3d52d5539e87de62ff1bdfd7423fd758cd5431.tar.gz
gentoo-ba3d52d5539e87de62ff1bdfd7423fd758cd5431.tar.bz2
gentoo-ba3d52d5539e87de62ff1bdfd7423fd758cd5431.zip
dev-lua/lua-term: initial commit
Diffstat (limited to 'dev-lua/lua-term/lua-term-0.3.ebuild')
-rw-r--r--dev-lua/lua-term/lua-term-0.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-lua/lua-term/lua-term-0.3.ebuild b/dev-lua/lua-term/lua-term-0.3.ebuild
new file mode 100644
index 000000000000..d1457e5fbae2
--- /dev/null
+++ b/dev-lua/lua-term/lua-term-0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+# Yes, upstream used different version numbers.
+# The rockspec version number is 0.3, but the version associated with
+# the tarball is 0.03.
+MY_PV=0.03
+
+DESCRIPTION="Terminal functions for Lua"
+HOMEPAGE="https://github.com/hoelzro/lua-term"
+SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o core.so core.c"
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+ -o core.so core.c || die
+}
+
+src_install() {
+ exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/term
+ doexe core.so
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+doins -r term
+}