summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-24 18:44:57 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-24 19:16:56 +0100
commit95510122348378b3b9623f6c28ddc43db8e4e9e3 (patch)
tree4973f03dbf09a0c51fec406f341228f824314b18 /dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild
parentdev-python/hypothesis: Remove myself from maintainers (diff)
downloadgentoo-95510122348378b3b9623f6c28ddc43db8e4e9e3.tar.gz
gentoo-95510122348378b3b9623f6c28ddc43db8e4e9e3.tar.bz2
gentoo-95510122348378b3b9623f6c28ddc43db8e4e9e3.zip
dev-ml/ocaml_intrinsics: bump to 0.15.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild')
-rw-r--r--dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild
new file mode 100644
index 000000000000..febba2e21179
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Invoke amd64 instructions (such as clz, popcnt, rdtsc, rdpmc)"
+HOMEPAGE="https://github.com/janestreet/ocaml_intrinsics/"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+DEPEND="
+ >=dev-lang/ocaml-4.08
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"