summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-17 21:18:52 +0000
committerSam James <sam@gentoo.org>2020-10-17 21:32:23 +0000
commit9a7a91c09387f59121295446510e1bdf2a04ddb2 (patch)
treef33094673be29567cf0875b636c5ca40d35f4b2a /dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild
parentsci-visualization/gr: Always depend on libX11 and libXt (diff)
downloadgentoo-9a7a91c09387f59121295446510e1bdf2a04ddb2.tar.gz
gentoo-9a7a91c09387f59121295446510e1bdf2a04ddb2.tar.bz2
gentoo-9a7a91c09387f59121295446510e1bdf2a04ddb2.zip
dev-ml/pcre-ocaml: restore 7.2.3
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild')
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild
new file mode 100644
index 000000000000..a35bab372f29
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND=">=dev-libs/libpcre-4.5
+ >=dev-lang/ocaml-4:="
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}