summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-17 23:45:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-18 00:39:45 +0100
commit7a16a29ca1492d11fe5182e4b739db921049c0ac (patch)
treeb0231dfdbbea9189cc553b1f8ad3f842bf163e00 /dev-ml
parentprofiles: Mask dev-libs/nwjs on musl (diff)
downloadgentoo-7a16a29ca1492d11fe5182e4b739db921049c0ac.tar.gz
gentoo-7a16a29ca1492d11fe5182e4b739db921049c0ac.tar.bz2
gentoo-7a16a29ca1492d11fe5182e4b739db921049c0ac.zip
dev-ml/atd: bump to 2.11.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/atd/Manifest1
-rw-r--r--dev-ml/atd/atd-2.11.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/atd/Manifest b/dev-ml/atd/Manifest
index 2450df1409c8..2d185c1b5e5b 100644
--- a/dev-ml/atd/Manifest
+++ b/dev-ml/atd/Manifest
@@ -1 +1,2 @@
DIST atd-2.10.0.tar.gz 3294787 BLAKE2B 7ef136e795a567eddc064986e1b78f3bbccf0433485c75742a989e7f48ca91b55444f01def67210c55de74f9283ee0316e6de0d38fc6d40a5ff499f16f0cbd63 SHA512 1f5ccd44cb5d7f41745d6399517f6b61c4dfc698a70f24594805ac07e0be240e2a44c1d992ad48622ed85a23384ecaab111b78e76e8e050d25d857356c3bf45b
+DIST atd-2.11.0.tar.gz 3300353 BLAKE2B e6f7f167a24eb6cd43900507e65646d251200db30ee01f8b4f1289f0e965af688bdcccaa6ef5590325ed9934ff4092554124c9b7c47687a2d05f271d8a245e86 SHA512 264e94015bebd096afd452845a63515c5efbd50d30c2cc19bf454079665a2119b2c837ffee809e67de9421020d3224ab2ed1ae8d99f301f32a056b1a7084a8ac
diff --git a/dev-ml/atd/atd-2.11.0.ebuild b/dev-ml/atd/atd-2.11.0.ebuild
new file mode 100644
index 000000000000..8cbc489b2d4c
--- /dev/null
+++ b/dev-ml/atd/atd-2.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Static types for JSON APIs"
+HOMEPAGE="https://github.com/ahrefs/atd/"
+SRC_URI="https://github.com/ahrefs/atd/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08:=[ocamlopt?]
+ >=dev-ml/cmdliner-1.1.1:=
+ >=dev-ml/yojson-2.0.2:=
+ dev-ml/biniou:=
+ dev-ml/easy-format:=
+ dev-ml/menhir:=
+ dev-ml/re:=
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dune-install atd \
+ atdgen \
+ atdgen-codec-runtime \
+ atdgen-runtime \
+ atdj \
+ atdpy \
+ atds \
+ atdts
+
+ dodoc CHANGES.md CONTRIBUTING.md README.md
+}