summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Event-RPC
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Event-RPC')
-rw-r--r--dev-perl/Event-RPC/Event-RPC-1.30.0.ebuild23
-rw-r--r--dev-perl/Event-RPC/Event-RPC-1.50.0.ebuild23
-rw-r--r--dev-perl/Event-RPC/Manifest2
-rw-r--r--dev-perl/Event-RPC/metadata.xml20
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/Event-RPC/Event-RPC-1.30.0.ebuild b/dev-perl/Event-RPC/Event-RPC-1.30.0.ebuild
new file mode 100644
index 000000000000..58c01caeac22
--- /dev/null
+++ b/dev-perl/Event-RPC/Event-RPC-1.30.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JRED
+MODULE_VERSION=1.03
+inherit perl-module
+
+DESCRIPTION="Event based transparent Client/Server RPC framework"
+
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="|| ( dev-perl/Event dev-perl/glib-perl )
+ dev-perl/IO-Socket-SSL
+ dev-perl/Net-SSLeay
+ virtual/perl-Storable"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Event-RPC/Event-RPC-1.50.0.ebuild b/dev-perl/Event-RPC/Event-RPC-1.50.0.ebuild
new file mode 100644
index 000000000000..6896848619b3
--- /dev/null
+++ b/dev-perl/Event-RPC/Event-RPC-1.50.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=JRED
+MODULE_VERSION=1.05
+inherit perl-module
+
+DESCRIPTION="Event based transparent Client/Server RPC framework"
+
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="|| ( dev-perl/Event dev-perl/glib-perl )
+ dev-perl/IO-Socket-SSL
+ dev-perl/Net-SSLeay
+ virtual/perl-Storable"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Event-RPC/Manifest b/dev-perl/Event-RPC/Manifest
new file mode 100644
index 000000000000..fcda6aa763ed
--- /dev/null
+++ b/dev-perl/Event-RPC/Manifest
@@ -0,0 +1,2 @@
+DIST Event-RPC-1.03.tar.gz 47011 SHA256 e97e96bc9294d8b3466cf9fcf4a157650ad1483dda3dd02d1b11793cbc429983 SHA512 d48f91f53dd41885163a089cd8df1b920e51b85bc972156a23bdb5112ab880b035d8759215d8c488738974a6f4ad29894073d49883f9f835d92fff9257ea0ffb WHIRLPOOL 3d389c9cc433f2321569a6bb47e9dc224a485f66fef7e28307b73534f826512360ac0f0e0a389fffb2a2817c16cd7b27f710e4b89c509ed23e723952be61f979
+DIST Event-RPC-1.05.tar.gz 48716 SHA256 6d8286cc24dc9c87d471ff8a361b471b00e7a141d6fd477d17303fe3dd634128 SHA512 817f3c6efccc9701d091d4ddb3dc6860efbb276150f1534a40315eb668074a77dac099b0f944a7507cda98aef1a59d4a5c460a9d3cef1bd0ffe40f88d1d5b214 WHIRLPOOL 5fe6419cf129d8243f6162efc170f57add0f19b16b2a5086d118b7a689ed860ab4953691d17f630fc9e5b28d56fbcda02dffe6d8654809d585a3bdeb4e75b706
diff --git a/dev-perl/Event-RPC/metadata.xml b/dev-perl/Event-RPC/metadata.xml
new file mode 100644
index 000000000000..5cbcc967e79f
--- /dev/null
+++ b/dev-perl/Event-RPC/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Event-RPC</remote-id>
+ <remote-id type="cpan-module">Event::RPC</remote-id>
+ <remote-id type="cpan-module">Event::RPC::AuthPasswdHash</remote-id>
+ <remote-id type="cpan-module">Event::RPC::Client</remote-id>
+ <remote-id type="cpan-module">Event::RPC::Connection</remote-id>
+ <remote-id type="cpan-module">Event::RPC::LogConnection</remote-id>
+ <remote-id type="cpan-module">Event::RPC::Logger</remote-id>
+ <remote-id type="cpan-module">Event::RPC::Loop</remote-id>
+ <remote-id type="cpan-module">Event::RPC::Loop::AnyEvent</remote-id>
+ <remote-id type="cpan-module">Event::RPC::Loop::Event</remote-id>
+ <remote-id type="cpan-module">Event::RPC::Loop::Glib</remote-id>
+ <remote-id type="cpan-module">Event::RPC::Message</remote-id>
+ <remote-id type="cpan-module">Event::RPC::Server</remote-id>
+ </upstream>
+</pkgmetadata>