summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-15 19:16:23 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-15 19:16:57 +1300
commit0da89c967f907abf9618f562bb413fd5c71d73e6 (patch)
tree9f03d76f2d7e87273e82e040c4e95f082c61342b /dev-perl/Template-DBI
parentnet-irc/hexchat: add python-3.6 support #616944 (diff)
downloadgentoo-0da89c967f907abf9618f562bb413fd5c71d73e6.tar.gz
gentoo-0da89c967f907abf9618f562bb413fd5c71d73e6.tar.bz2
gentoo-0da89c967f907abf9618f562bb413fd5c71d73e6.zip
dev-perl/Template-DBI: EAPI6, fix for .-in-@INC failing test bug #623120
- EAPI6 - Patch '.' in @INC failing test Bug: https://bugs.gentoo.org/623120 Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Template-DBI')
-rw-r--r--dev-perl/Template-DBI/Template-DBI-2.650.0-r2.ebuild25
-rw-r--r--dev-perl/Template-DBI/files/Template-DBI-2.65-no-dot-inc.patch40
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-perl/Template-DBI/Template-DBI-2.650.0-r2.ebuild b/dev-perl/Template-DBI/Template-DBI-2.650.0-r2.ebuild
new file mode 100644
index 000000000000..6f9f1eb9648b
--- /dev/null
+++ b/dev-perl/Template-DBI/Template-DBI-2.650.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=REHSACK
+DIST_VERSION=2.65
+inherit perl-module
+
+DESCRIPTION="DBI plugin for the Template Toolkit"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-aix ~x86-fbsd ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-perl/DBI-1.612
+ >=dev-perl/Template-Toolkit-2.22"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/MLDBM
+ >=dev-perl/SQL-Statement-1.28
+ )"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.65-no-dot-inc.patch"
+)
diff --git a/dev-perl/Template-DBI/files/Template-DBI-2.65-no-dot-inc.patch b/dev-perl/Template-DBI/files/Template-DBI-2.65-no-dot-inc.patch
new file mode 100644
index 000000000000..803f84123cc6
--- /dev/null
+++ b/dev-perl/Template-DBI/files/Template-DBI-2.65-no-dot-inc.patch
@@ -0,0 +1,40 @@
+From e55f99e77f12ac5ece679e159e577ef91eee0ba4 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Mon, 15 Jan 2018 16:05:06 +1300
+Subject: Fix test failures on Perl 5.26+ w/ PERL_USE_UNSAFE_INC=0
+
+In future perls, CPAN.pm and Test::Harness will no longer be able to
+migitigate this failure mode by internally doing:
+
+ $ENV{PERL_USE_UNSAFE_INC}=1 unless exists $ENV{PERL_USE_UNSAFE_INC}
+
+This fixes this problem by avoiding the need for @INC traversal by
+using a literal path ( eg: one with a / or a ./ prefix ), not an
+"@INC-relative path" ( eg: Foo/Baz.pm ), and breaking the reliance on
+"." in @INC
+
+Additionally, this replaces "do" with "require" to give automatic error
+handling, instead of continuing when the library load fails.
+
+Bug: https://bugs.gentoo.org/623120
+Bug: https://rt.cpan.org/Ticket/Display.html?id=124080
+---
+ t/dbi.t | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/t/dbi.t b/t/dbi.t
+index 7193210..7b6dccf 100644
+--- a/t/dbi.t
++++ b/t/dbi.t
+@@ -16,7 +16,7 @@
+ use strict;
+ use warnings;
+
+-do "t/lib.pl";
++require "./t/lib.pl";
+
+ use Template::Test;
+ use Template::Stash;
+--
+2.15.1
+