summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-06-11 15:06:16 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-06-11 15:25:54 -0400
commit8752b48684ce0f6d5bd22480ecfd439bd62c3444 (patch)
tree9042668fa0f149e1f73acb49a68a1aed29ac5fcb /dev-php/PEAR-Structures_Graph
parentdev-php/PEAR-Mail_Mime: add 1.10.12 (diff)
downloadgentoo-8752b48684ce0f6d5bd22480ecfd439bd62c3444.tar.gz
gentoo-8752b48684ce0f6d5bd22480ecfd439bd62c3444.tar.bz2
gentoo-8752b48684ce0f6d5bd22480ecfd439bd62c3444.zip
dev-php/PEAR-Structures_Graph: add 1.2.0
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php/PEAR-Structures_Graph')
-rw-r--r--dev-php/PEAR-Structures_Graph/Manifest1
-rw-r--r--dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.2.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-Structures_Graph/Manifest b/dev-php/PEAR-Structures_Graph/Manifest
index 96dc56ea2f4e..642d4147fef1 100644
--- a/dev-php/PEAR-Structures_Graph/Manifest
+++ b/dev-php/PEAR-Structures_Graph/Manifest
@@ -1 +1,2 @@
DIST Structures_Graph-1.1.1.tgz 12402 BLAKE2B 049fc9a15b1ea46a8cb63576174b4b1cc491dd31794b8a1f9526958f6d54902069d16a7158615fc9708ba88bf46e0b021baa01596e443f8c6d9a7f551dac8b23 SHA512 cd4feb265e1aa05de348645dfc0b8e336486cb02c553dd8fcacb0a1eab452bf54108e07864395d55e0c92f4ffd338a5ae846b2dc28804bb23f03c91864ef0284
+DIST Structures_Graph-1.2.0.tgz 12507 BLAKE2B 2dca23da6d9b42aefee9c10f0ff3cbd0946186b332d0f56da65d068e02b9858c9113568b9850c4b1aae0ed4dd15b2c463765f2ed3d232083d5d6ef130443b14f SHA512 a256e6be4ac2011678942d97e39975973aed8b8dbab535325810ae97fb322a4aaac8daf1302f34f239a2b38649ddb39c1ae0a8c325aa1c6cbd90208adf9973dc
diff --git a/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.2.0.ebuild b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.2.0.ebuild
new file mode 100644
index 000000000000..f4f914046d5a
--- /dev/null
+++ b/dev-php/PEAR-Structures_Graph/PEAR-Structures_Graph-1.2.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Graph datastructure manipulation library"
+HOMEPAGE="https://pear.php.net/package/Structures_Graph"
+SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="dev-lang/php:*"
+PDEPEND="dev-php/PEAR-PEAR"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Structures
+}