summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-19 22:54:15 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-03-19 22:54:55 +0100
commitb4a7dfdb50525cca2779f081910d4ed8df6e689c (patch)
tree0a2db4529bb1acbf4ed4220809aa6818af31fa78 /dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild
parentdev-php/symfony-process: bump to v3.4.38 (diff)
downloadgentoo-b4a7dfdb50525cca2779f081910d4ed8df6e689c.tar.gz
gentoo-b4a7dfdb50525cca2779f081910d4ed8df6e689c.tar.bz2
gentoo-b4a7dfdb50525cca2779f081910d4ed8df6e689c.zip
dev-php/xdebug-handler: bump to v1.4.1
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild')
-rw-r--r--dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild b/dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild
new file mode 100644
index 000000000000..806a747fbd38
--- /dev/null
+++ b/dev-php/xdebug-handler/xdebug-handler-1.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restart a CLI process without loading the xdebug extension"
+HOMEPAGE="https://github.com/composer/xdebug-handler"
+SRC_URI="https://github.com/composer/xdebug-handler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2"
+
+src_install() {
+ insinto /usr/share/php/Composer/XdebugHandler
+ doins src/*.php "${FILESDIR}/autoload.php"
+ dodoc README.md
+}