summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-11-18 14:12:38 +0000
committerSam James <sam@gentoo.org>2024-11-25 00:02:01 +0000
commitd1d1d34261a4e07a9f779d4f274ea0ce77f4dbd9 (patch)
tree4eccdea0cc36aee28aaa554faac12b1750fcdad1 /dev-php
parentdev-php/pecl-radius: add php 8.3 support (diff)
downloadgentoo-d1d1d34261a4e07a9f779d4f274ea0ce77f4dbd9.tar.gz
gentoo-d1d1d34261a4e07a9f779d4f274ea0ce77f4dbd9.tar.bz2
gentoo-d1d1d34261a4e07a9f779d4f274ea0ce77f4dbd9.zip
dev-php/pecl-stomp: add php 8.3 support
Bug: https://bugs.gentoo.org/943650 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39359 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.3-r1.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..4662ba6ae5c2
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_PHP="php8-2 php8-3"
+PHP_EXT_NAME="stomp"
+PHP_EXT_NEEDED_USE="ssl(-)?"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP extension to communicate with Stomp message brokers"
+HOMEPAGE="https://pecl.php.net/package/stomp"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples ssl test"
+RESTRICT="!test? ( test )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=(
+ --enable-stomp
+ --with-openssl-dir=$(usex ssl yes no)
+ )
+ php-ext-source-r3_src_configure
+}