summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-01-02 05:39:03 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-02 16:13:45 +0000
commit8c959629a0c8e4c103ee3dbf6f106e1638295854 (patch)
tree5c8c7a391a6842abce784d49c2e70dc7b49e443f /dev-python/CommonMark
parentdev-python/pydot-ng: initial import (diff)
downloadgentoo-8c959629a0c8e4c103ee3dbf6f106e1638295854.tar.gz
gentoo-8c959629a0c8e4c103ee3dbf6f106e1638295854.tar.bz2
gentoo-8c959629a0c8e4c103ee3dbf6f106e1638295854.zip
dev-python/CommonMark: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/CommonMark')
-rw-r--r--dev-python/CommonMark/CommonMark-0.5.4.ebuild34
-rw-r--r--dev-python/CommonMark/Manifest1
-rw-r--r--dev-python/CommonMark/metadata.xml19
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/CommonMark/CommonMark-0.5.4.ebuild b/dev-python/CommonMark/CommonMark-0.5.4.ebuild
new file mode 100644
index 000000000000..3f2c494a7376
--- /dev/null
+++ b/dev-python/CommonMark/CommonMark-0.5.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python parser for the CommonMark Markdown spec"
+HOMEPAGE="https://github.com/rtfd/CommonMark-py"
+LICENSE="BSD"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+RDEPEND="
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# unrestrict for versions >= 0.7.2
+RESTRICT=test
+
+python_test() {
+ LC_ALL='en_US.utf8' LC_CTYPE='en_US.utf8' LANG=en_US.utf8 PYTHONIOENCODING=UTF-8 \
+ esetup.py test
+}
diff --git a/dev-python/CommonMark/Manifest b/dev-python/CommonMark/Manifest
new file mode 100644
index 000000000000..0df81f3c9689
--- /dev/null
+++ b/dev-python/CommonMark/Manifest
@@ -0,0 +1 @@
+DIST CommonMark-0.5.4.tar.gz 120316 SHA256 34d73ec8085923c023930dfc0bcd1c4286e28a2a82de094bb72fabcc0281cbe5 SHA512 1983714a50a627f30f86af0d02dad9e52cb7b0ffce29691d0e740f587e599ead6de2412d72b895b7df772e1c81e171e56dfecaf593e611af65bd5798632a98ad WHIRLPOOL f375b772faff450af98d73b3559dabe7b7369951cd8cf9ea45046bf5de875022212b7e92daee3fa7d3fb63d44894a301991a4561ac8a8b0c78eef64c83062fad
diff --git a/dev-python/CommonMark/metadata.xml b/dev-python/CommonMark/metadata.xml
new file mode 100644
index 000000000000..fc5b696a8da1
--- /dev/null
+++ b/dev-python/CommonMark/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pure Python port of jgm’s commonmark.js, a Markdown parser and
+ renderer for the CommonMark specification, using only native
+ modules. Once both this project and the CommonMark specification
+ are stable we will release the first 1.0 version and attempt to
+ keep up to date with changes in commonmark.js.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">CommonMark</remote-id>
+ <remote-id type="github">rtfd/CommonMark.py</remote-id>
+ </upstream>
+</pkgmetadata>