summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-31 07:52:36 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-31 07:52:36 +0100
commitbd30f6950cf884fa934fae3fdee0cfbd4e06c086 (patch)
tree8772a523243b49dd8d38b04a215a703c0d11f0c5 /dev-python/aiohappyeyeballs
parentdev-python/jupyterlab: Bump to 4.0.12 (diff)
downloadgentoo-bd30f6950cf884fa934fae3fdee0cfbd4e06c086.tar.gz
gentoo-bd30f6950cf884fa934fae3fdee0cfbd4e06c086.tar.bz2
gentoo-bd30f6950cf884fa934fae3fdee0cfbd4e06c086.zip
dev-python/aiohappyeyeballs: Bump to 2.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohappyeyeballs')
-rw-r--r--dev-python/aiohappyeyeballs/Manifest1
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
index e39deb3d9b06..5675ae97746c 100644
--- a/dev-python/aiohappyeyeballs/Manifest
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -1 +1,2 @@
DIST aiohappyeyeballs-2.3.1.gh.tar.gz 46348 BLAKE2B 6d20cd6db085b7d7bd0b2a18eec01dbd569eb64be7ae953eadcd07e161442637fee9ec63c3bb2253d11fea210d9ab6e8a130f9f036652a8965325db9fc30d3dd SHA512 c02a12a269e0733f653df9fedc150aea8ad061fb8b1f67e3519d6c2e8ea92f8ad3360b4eaacc0e55f51e81f57cc9c8aa82dbe0fcd9779dcd8151a3f944f28847
+DIST aiohappyeyeballs-2.3.2.gh.tar.gz 46204 BLAKE2B 85a050910181e7acd6520ae8126e6e1656b5d5e7d869bca481af5fe65b52bf1d4dc0502d2e0cce702c60dc9420757fc892a91a600a73925adce6990fc224bb1a SHA512 5638dabb06c9d0182e21371470d612ec78a1a8981a0720318b0f4fc0569b7c556adfba6297b5bec75726e106f5a6335acfb19bd5322e43e5ebc4f71d4457424c
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.2.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.2.ebuild
new file mode 100644
index 000000000000..23130e159041
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}