summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ansi2html
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/Manifest2
-rw-r--r--dev-python/ansi2html/ansi2html-1.0.7.ebuild37
-rw-r--r--dev-python/ansi2html/ansi2html-1.1.0.ebuild39
-rw-r--r--dev-python/ansi2html/files/ansi2html-0.9.1-fix-0-control-code.patch28
-rw-r--r--dev-python/ansi2html/files/ansi2html-0.9.1-fix-sys-argv-in-tests.patch27
-rw-r--r--dev-python/ansi2html/metadata.xml13
6 files changed, 146 insertions, 0 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
new file mode 100644
index 000000000000..6b65e06957b9
--- /dev/null
+++ b/dev-python/ansi2html/Manifest
@@ -0,0 +1,2 @@
+DIST ansi2html-1.0.7.tar.gz 52307 SHA256 fcc732e4d10627f8060921c54c751ff181a098ceccd116311b4c6e26ec2ea5cd SHA512 75f6601315e47ec5fbd28fb360316e55f8204cf81f9ed9f6374318436b04b1baf86b556885a5a9a1f67a3495357b89d74ad23d3b0680817c09b5d9e82eb4c1f6 WHIRLPOOL 47834d7efc2fe475d2d588b73fc3dd641c37147e574d0ef4e57c997f3a090eb3da8d73aa6f2ad02479d32a82b55fd0c6dc45a4e8593d6598086bed71c3486df2
+DIST ansi2html-1.1.0.tar.gz 51514 SHA256 537fc4ececf872f83d5cbd218fb64bb49304d258487e283736bb9e5e64319ad3 SHA512 2121c91c821a89d63fcb6c27a8a088968a150a447c5c2a270b781aabd19e07387e59bc1c291e818569c4bafe495c2d3d2c2c6f172406fa830467e3ad541e3e21 WHIRLPOOL db8292f3ebd434a3507ea4f55c32c80e62bbe06a80f9baf2d21089ae27b6a3365cea1e9be4d16d9ed050d01402bdccfad477a8c7b5d19004fa6d250f87d9a6a9
diff --git a/dev-python/ansi2html/ansi2html-1.0.7.ebuild b/dev-python/ansi2html/ansi2html-1.0.7.ebuild
new file mode 100644
index 000000000000..83f388cb90d6
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="http://pypi.python.org/pypi/ansi2html https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ chmod -x "${S}"/tests/* || die
+ esetup.py check
+ esetup.py test
+}
+
+python_install_all() {
+ doman man/ansi2html.1
+ DOCS=( README.rst man/ansi2html.1.txt )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ansi2html/ansi2html-1.1.0.ebuild b/dev-python/ansi2html/ansi2html-1.1.0.ebuild
new file mode 100644
index 000000000000..3a0a68e5f40c
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="http://pypi.python.org/pypi/ansi2html https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ chmod -x "${S}"/tests/* || die
+ esetup.py check
+ esetup.py test
+}
+
+python_install_all() {
+ doman man/ansi2html.1
+ DOCS=( README.rst man/ansi2html.1.txt )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ansi2html/files/ansi2html-0.9.1-fix-0-control-code.patch b/dev-python/ansi2html/files/ansi2html-0.9.1-fix-0-control-code.patch
new file mode 100644
index 000000000000..6e51d3f1d975
--- /dev/null
+++ b/dev-python/ansi2html/files/ansi2html-0.9.1-fix-0-control-code.patch
@@ -0,0 +1,28 @@
+From f4371f16fd9ba9bffdd32a877b32f78222aef87c Mon Sep 17 00:00:00 2001
+From: Corentin Chary <corentin.chary@gmail.com>
+Date: Sun, 22 Jul 2012 09:25:15 +0200
+Subject: [PATCH 3/3] The 0 control code could be at the end of a sequence
+
+Example: u"\x1b[32;01m * \x1b[39;49;00m *"
+Note that here 39 and 49 "reset to default" codes are still
+not handled.
+---
+ ansi2html/converter.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ansi2html/converter.py b/ansi2html/converter.py
+index 0609a9e..23be2d0 100755
+--- a/ansi2html/converter.py
++++ b/ansi2html/converter.py
+@@ -147,7 +147,7 @@ class Ansi2HTMLConverter(object):
+ if params[0] in [38, 48]:
+ params = ["%i-%i" % (params[0], params[2])] + params[3:]
+
+- if params == [0]:
++ if 0 in params:
+ # If the control code 0 is present, close all tags we've
+ # opened so far. i.e. reset all attributes
+ yield '</span>' * n_open
+--
+1.7.9.5
+
diff --git a/dev-python/ansi2html/files/ansi2html-0.9.1-fix-sys-argv-in-tests.patch b/dev-python/ansi2html/files/ansi2html-0.9.1-fix-sys-argv-in-tests.patch
new file mode 100644
index 000000000000..9e8fbe38c0fc
--- /dev/null
+++ b/dev-python/ansi2html/files/ansi2html-0.9.1-fix-sys-argv-in-tests.patch
@@ -0,0 +1,27 @@
+From d70863b135d959a6e79cf3019700cac302336abe Mon Sep 17 00:00:00 2001
+From: Corentin Chary <corentin.chary@gmail.com>
+Date: Sun, 22 Jul 2012 09:24:52 +0200
+Subject: [PATCH 2/3] Always patch sys.argv when calling main()
+
+---
+ tests/test_ansi2html.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/tests/test_ansi2html.py b/tests/test_ansi2html.py
+index 00b794f..c961859 100644
+--- a/tests/test_ansi2html.py
++++ b/tests/test_ansi2html.py
+@@ -45,8 +45,9 @@ class TestAnsi2HTML(unittest.TestCase):
+ actual = html[idx].strip()
+ self.assertEqual(expected, actual)
+
++ @patch("sys.argv", new_callable=lambda: ["ansi2html"])
+ @patch("sys.stdout", new_callable=six.StringIO)
+- def test_conversion_as_command(self, mock_stdout):
++ def test_conversion_as_command(self, mock_stdout, mock_argv):
+ with open(join(_here, "ansicolor.txt"), "rb") as input:
+ test_data = "".join(read_to_unicode(input))
+
+--
+1.7.9.5
+
diff --git a/dev-python/ansi2html/metadata.xml b/dev-python/ansi2html/metadata.xml
new file mode 100644
index 000000000000..3936c4a0cc84
--- /dev/null
+++ b/dev-python/ansi2html/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ansi2html</remote-id>
+ <remote-id type="github">ralphbean/ansi2html</remote-id>
+ </upstream>
+</pkgmetadata>