summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-06-22 21:07:50 +0200
committerSebastian Pipping <sping@gentoo.org>2024-06-22 21:09:28 +0200
commita80d16bba8ffcdd88b40639a910b4f563a153d1b (patch)
treecc3f9df02ad22f62de4a2e12a64bb72d6c488f7e /dev-python/ansi2html
parentnet-misc/gallery-dl: bump to 1.27.1 (diff)
downloadgentoo-a80d16bba8ffcdd88b40639a910b4f563a153d1b.tar.gz
gentoo-a80d16bba8ffcdd88b40639a910b4f563a153d1b.tar.bz2
gentoo-a80d16bba8ffcdd88b40639a910b4f563a153d1b.zip
dev-python/ansi2html: 1.9.2
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-python/ansi2html')
-rw-r--r--dev-python/ansi2html/Manifest1
-rw-r--r--dev-python/ansi2html/ansi2html-1.9.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ansi2html/Manifest b/dev-python/ansi2html/Manifest
index 851f59158144..aa650d57609b 100644
--- a/dev-python/ansi2html/Manifest
+++ b/dev-python/ansi2html/Manifest
@@ -1 +1,2 @@
DIST ansi2html-1.9.1.tar.gz 44288 BLAKE2B ff83d2a9fe74766324515e7ccde5c6d157f836d655c6c55a07f0b9c4ab5df9c8a840f0c35e752a3e24f3e12fbd73565c2906382d77c2daf5951e861e18bdcb46 SHA512 1ffeffdd4f861b809c424b5b9e7d07212aaf1b5ef483a2820f128f815002628c823b5701652b0770ed182f0585052f040b55fca5db31e4690be86c49553105b3
+DIST ansi2html-1.9.2.tar.gz 44300 BLAKE2B 6c39a9525a5fe0c7f02b45f56ea515e6b07280cb74a88d54db5e33c77fb679f6ebb446edf50add3d68832ea877ed8861bc1a9f2116ab1214d2a6b3acfbfae19a SHA512 c465259d4c9ea82725bcd8cd286246b806b1bfde06f89b52b1cc3cd5c514be92a19ffcfd147417d64ce6da6627678baabc7ff05226ed392343cdb0496bd375eb
diff --git a/dev-python/ansi2html/ansi2html-1.9.2.ebuild b/dev-python/ansi2html/ansi2html-1.9.2.ebuild
new file mode 100644
index 000000000000..87b3e5333dd5
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.9.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="
+ https://pypi.org/project/ansi2html/
+ https://github.com/pycontribs/ansi2html/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest