summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-10 09:54:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-10 10:48:51 +0200
commitff5315fb668a91445664f85c0cf9278b6ae0faec (patch)
tree8789ac393a033564b1064659b4dde3e5ecf39ddf /dev-python/asttokens/asttokens-2.0.4.ebuild
parentdev-python/astroid: Enable py3.9 (diff)
downloadgentoo-ff5315fb668a91445664f85c0cf9278b6ae0faec.tar.gz
gentoo-ff5315fb668a91445664f85c0cf9278b6ae0faec.tar.bz2
gentoo-ff5315fb668a91445664f85c0cf9278b6ae0faec.zip
dev-python/asttokens: New package, deep dep of sentry-sdk
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asttokens/asttokens-2.0.4.ebuild')
-rw-r--r--dev-python/asttokens/asttokens-2.0.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/asttokens/asttokens-2.0.4.ebuild b/dev-python/asttokens/asttokens-2.0.4.ebuild
new file mode 100644
index 000000000000..1cb502acd191
--- /dev/null
+++ b/dev-python/asttokens/asttokens-2.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Annotate Python AST trees with source text and token information"
+HOMEPAGE="
+ https://github.com/gristlabs/asttokens/
+ https://pypi.org/project/asttokens/"
+SRC_URI="
+ https://github.com/gristlabs/asttokens/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/astroid[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.9 ]] && deselect+=(
+ # invalid syntax
+ --deselect
+ tests/test_astroid.py::TestAstroid::test_fixture9
+ --deselect
+ tests/test_astroid.py::TestAstroid::test_splat
+ --deselect
+ tests/test_astroid.py::TestAstroid::test_sys_modules
+ --deselect
+ tests/test_mark_tokens.py::TestMarkTokens::test_fixture9
+ --deselect
+ tests/test_mark_tokens.py::TestMarkTokens::test_splat
+ --deselect
+ tests/test_mark_tokens.py::TestMarkTokens::test_sys_modules
+ )
+ pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
+}