summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-13 06:56:58 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-13 07:55:00 +0100
commit76fbe9836cb6d8ba7b6c38f2edaaded239822d5b (patch)
tree01f04400decaa97f6994b78da931733de1daf448 /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.59 (diff)
downloadgentoo-76fbe9836cb6d8ba7b6c38f2edaaded239822d5b.tar.gz
gentoo-76fbe9836cb6d8ba7b6c38f2edaaded239822d5b.tar.bz2
gentoo-76fbe9836cb6d8ba7b6c38f2edaaded239822d5b.zip
dev-python/boto3: Bump to 1.35.59
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.59.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 8bbb39113d7e..a9f886eb6f4f 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.35.49.gh.tar.gz 878577 BLAKE2B 8f9ddf29eaad2f91a9ba670b268ac987f7f8
DIST boto3-1.35.54.gh.tar.gz 882727 BLAKE2B 398e7743d30700856b15440c217d40e88aec4e58669009f68392e108373f2e57ff3c384be9bdc3873b102686df7f0e05f53d4518b149e982e0893473919db3cb SHA512 bfddb7c4b3816edc2b572bd6f412c0d085296df17b552930dfc9bb108c7100190da1f58f5f701d3ec3c36e6deb88c93e5af5bfc68963b76fc7c950d456815ec5
DIST boto3-1.35.57.gh.tar.gz 885077 BLAKE2B 4f3a29db5e76c706fbfd0afb3ec05d5518e69f3fd26d15e79024fb898d874818fa21031187d66078a4ebd107cce9461000e37506886f337049bd821e20933563 SHA512 19f951c04452203c070243bd8c944183221b51d9853efc19d33002af57c7d59c1967e8a7b606e56f772f35576ec6e1b52e2037138ba01a28f13685a49458c7d4
DIST boto3-1.35.58.gh.tar.gz 885941 BLAKE2B d561cf27dba3177789047cf8ac9cc3e5b7a669f26cae948c5d0c458464518eb16ea2525ef0b1c2118acaaeb348e7435947eca69f37d42affe3b3b8dfd199ddbc SHA512 9988693c33dab2294f302e9e9434fd9c681fc43042ba6772a36d36df9ba60f5884eeecaa60a17e6087a07d35c9691ecb16ee3920c3859335817e49b5f97247ee
+DIST boto3-1.35.59.gh.tar.gz 886122 BLAKE2B 2eb1378f810bada55c5c6c1a6c70c16c073ddc68d30850ff50b5f604dd15b386bcd0985b81b39fc79801f552eab7f289aaf4ca5377b958b2d28ad0b193e7886d SHA512 ab771736bd88419d50bb11db36f7c308da4816222379d45dfa97557a3c3c43ffb9a9521bc92cf0a4dd2631d01c94f6f9c728517c02a9787e49d98dd860f7e128
diff --git a/dev-python/boto3/boto3-1.35.59.ebuild b/dev-python/boto3/boto3-1.35.59.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.59.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}