summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 13:17:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 13:21:20 +0100
commitb9be2261057a675c403e153b13cb77da5f23ae1a (patch)
tree2cacb01257c62c800ed5ca0c2acc3b16bbde4ea3 /dev-python/configobj
parentdev-python/carbon: Switch to PEP 517 build (diff)
downloadgentoo-b9be2261057a675c403e153b13cb77da5f23ae1a.tar.gz
gentoo-b9be2261057a675c403e153b13cb77da5f23ae1a.tar.bz2
gentoo-b9be2261057a675c403e153b13cb77da5f23ae1a.zip
dev-python/configobj: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configobj')
-rw-r--r--dev-python/configobj/configobj-5.0.6-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/configobj/configobj-5.0.6-r2.ebuild b/dev-python/configobj/configobj-5.0.6-r2.ebuild
new file mode 100644
index 000000000000..173e79278757
--- /dev/null
+++ b/dev-python/configobj/configobj-5.0.6-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple config file reader and writer"
+HOMEPAGE="http://www.voidspace.org.uk/python/configobj.html https://pypi.org/project/configobj/"
+SRC_URI="https://github.com/DiffSK/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-fix-py2-tests.patch" )
+
+distutils_enable_tests pytest