summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-12-25 19:15:49 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-12-25 19:15:49 +0200
commitabeaf796718000723394bb9d44db22576c15fbf8 (patch)
tree17ae6a56d82ee5f337934612d66f0c09e0cee802 /dev-python/cwcwidth/cwcwidth-0.1.6.ebuild
parentvirtual/rust: Stabilize 1.56.1 arm, #821898 (diff)
downloadgentoo-abeaf796718000723394bb9d44db22576c15fbf8.tar.gz
gentoo-abeaf796718000723394bb9d44db22576c15fbf8.tar.bz2
gentoo-abeaf796718000723394bb9d44db22576c15fbf8.zip
dev-python/cwcwidth: add 0.1.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/cwcwidth/cwcwidth-0.1.6.ebuild')
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.6.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.6.ebuild
new file mode 100644
index 000000000000..a7b0fb7a42b8
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}