summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-19 15:49:42 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-19 18:29:11 +0200
commit8215adada89e2968fef348afa1f1403edb0ccc2e (patch)
tree9c1ae315febe04b04bb52cfe40c5ce5f60b0062c /dev-python/dbus-python
parentdev-python/pygobject: Add python3.5 support (diff)
downloadgentoo-8215adada89e2968fef348afa1f1403edb0ccc2e.tar.gz
gentoo-8215adada89e2968fef348afa1f1403edb0ccc2e.tar.bz2
gentoo-8215adada89e2968fef348afa1f1403edb0ccc2e.zip
dev-python/dbus-python: Add python3.5 support
Add missing ${PYTHON_REQUIRED_USE} Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild b/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild
index 8b025358fb72..bc9ef383e625 100644
--- a/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit autotools eutils python-r1
@@ -17,9 +17,12 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~m68k-mint"
IUSE="doc examples test"
# API docs generated with epydoc, which is python2-only
-REQUIRED_USE="doc? ( python_targets_python2_7 )"
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ doc? ( python_targets_python2_7 )"
-RDEPEND=">=dev-libs/dbus-glib-0.100:=
+RDEPEND="
+ >=dev-libs/dbus-glib-0.100:=
>=sys-apps/dbus-1.6:=
${PYTHON_DEPS}"
DEPEND="${RDEPEND}