summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 09:35:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 09:41:29 +0200
commit782d86bd2dba251e5793f15c0de7166e50afdace (patch)
treedb4ae6f0cf412f7b98ca6da4f80720bb3df63b7a /dev-python/debugpy/debugpy-1.4.1.ebuild
parentdev-python/cvxopt: Remove old (diff)
downloadgentoo-782d86bd2dba251e5793f15c0de7166e50afdace.tar.gz
gentoo-782d86bd2dba251e5793f15c0de7166e50afdace.tar.bz2
gentoo-782d86bd2dba251e5793f15c0de7166e50afdace.zip
dev-python/debugpy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/debugpy/debugpy-1.4.1.ebuild')
-rw-r--r--dev-python/debugpy/debugpy-1.4.1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/debugpy/debugpy-1.4.1.ebuild b/dev-python/debugpy/debugpy-1.4.1.ebuild
deleted file mode 100644
index 9e2e9b284cd9..000000000000
--- a/dev-python/debugpy/debugpy-1.4.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the Debug Adapter Protocol for Python"
-HOMEPAGE="https://github.com/microsoft/debugpy/ https://pypi.org/project/debugpy/"
-SRC_URI="https://github.com/microsoft/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~sparc"
-
-# There is not enough time in the universe for this test suite
-RESTRICT="test"
-
-# These files are included pre-built in the sources
-# TODO: Investigate what this is and if/how we can compile this properly
-QA_PREBUILT="
- /usr/lib/python*/site-packages/${PN}/_vendored/pydevd/pydevd_attach_to_process/attach_linux_*.so
-"
-
-python_prepare_all() {
- # Drop unnecessary and unrecognized option
- # __main__.py: error: unrecognized arguments: -n8
- # Do not timeout
- sed -i \
- -e 's/-n8//g' \
- -e '/timeout/d' \
- pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
-
-distutils_enable_tests pytest