summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/dogpile-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/dogpile-core')
-rw-r--r--dev-python/dogpile-core/Manifest1
-rw-r--r--dev-python/dogpile-core/dogpile-core-0.4.1.ebuild26
-rw-r--r--dev-python/dogpile-core/metadata.xml18
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/dogpile-core/Manifest b/dev-python/dogpile-core/Manifest
new file mode 100644
index 000000000000..9507d33c43ad
--- /dev/null
+++ b/dev-python/dogpile-core/Manifest
@@ -0,0 +1 @@
+DIST dogpile.core-0.4.1.tar.gz 99534 SHA256 af2555702811d56846778d39451cf822b04b3f13347080c121a4977fefdfcbff SHA512 f4c37297788677afe6ab17ba5aa928f9770b0edbd1a675cd4ad512ef0c15cf1e2d765d9b7a9fe3638f0a646e0ad51d54c9b4ded33611022744226bfde1aa9896 WHIRLPOOL 09677b564eee99202e66bba97b9e8db36a75aa1c3e86616a043db8b6bff318031c2afe72f9c243e19cc106e546aa9cc422820aeee505a7f5627f64c808af1eec
diff --git a/dev-python/dogpile-core/dogpile-core-0.4.1.ebuild b/dev-python/dogpile-core/dogpile-core-0.4.1.ebuild
new file mode 100644
index 000000000000..44e7416b498f
--- /dev/null
+++ b/dev-python/dogpile-core/dogpile-core-0.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lock which allows a thread to generate an expensive resource while other threads use the old value"
+HOMEPAGE="https://bitbucket.org/zzzeek/dogpile.core"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.core/dogpile.core-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.core-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}
diff --git a/dev-python/dogpile-core/metadata.xml b/dev-python/dogpile-core/metadata.xml
new file mode 100644
index 000000000000..79fa0556ac62
--- /dev/null
+++ b/dev-python/dogpile-core/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A "dogpile" lock, one which allows a single thread to generate an
+ expensive resource while other threads use the "old" value,
+ until the "new" value is ready.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">dogpile.core</remote-id>
+ <remote-id type="bitbucket">zzzeek/dogpile.core</remote-id>
+ </upstream>
+</pkgmetadata>