summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-06 04:29:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-06 05:07:39 +0200
commit208246a3f30c703ef4b020125359662a7e0f65f0 (patch)
tree0623e038e5a2b6207b49e7ebcf84a9da3259afa4 /dev-python/fido2
parentdev-python/beautifulsoup4: Bump to 4.12.1 (diff)
downloadgentoo-208246a3f30c703ef4b020125359662a7e0f65f0.tar.gz
gentoo-208246a3f30c703ef4b020125359662a7e0f65f0.tar.bz2
gentoo-208246a3f30c703ef4b020125359662a7e0f65f0.zip
dev-python/fido2: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-1.1.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
index f84f6aff5fc0..d89c11e733ff 100644
--- a/dev-python/fido2/Manifest
+++ b/dev-python/fido2/Manifest
@@ -1,2 +1,3 @@
DIST fido2-0.9.3.tar.gz 217894 BLAKE2B ccc3a9b59045216037664b5bf4b969a79b86b300f67fc4253b563acbbee98912ea076996772f17b88141d2a36a933b4926de96f05c53e204d0bb4eaaa2daad6b SHA512 f105c347784cdfab88ab08852227d24f4bca623145f7f76bd066dadab6ada1eae751934fd4dc7436a5c5fb3a0ed2fc4d5c59bb2a93888d470028f0713ca7e09e
DIST fido2-1.1.0.tar.gz 243526 BLAKE2B 48a6466c1ad3723d3d5f2e22ef59b4b49ebc3231739ffffdb25349d466c23f5cdc063908ea1adb944041f646d0bd0648d66acdaae0e72a9715e4bc365f449c12 SHA512 df7fcf205a5c124daf14c4bb7742aa16def1e912490c3b967dd940fdb21baf1a933130eab276af7c03fb46fb779a5a2b8e5fa3d8e3cd379297c23d9f39cadba4
+DIST fido2-1.1.1.tar.gz 247150 BLAKE2B 136d539db8bcaa5398e7ac2c2d0733c902b370c1b30491181164cc2f329c44dd81a42f19374ff6bd89fc757fe33580ef39bdb016e9f93f5ea17b12f22143761d SHA512 8078acbc85e277ddbf7a508f17c34f581eb8978786b5e43b4ede7de24138f07eee7f81aa307295305a42b286900a73903f269afd2a66aee9650fe05ac6aa1901
diff --git a/dev-python/fido2/fido2-1.1.1.ebuild b/dev-python/fido2/fido2-1.1.1.ebuild
new file mode 100644
index 000000000000..6724b3858747
--- /dev/null
+++ b/dev-python/fido2/fido2-1.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="
+ https://github.com/Yubico/python-fido2/
+ https://pypi.org/project/fido2/
+"
+SRC_URI="
+ https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0 BSD-2 MIT MPL-2.0"
+SLOT="0/1.0" # Bumped every time a backwards-incompatible version is released
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+RDEPEND="
+ <dev-python/cryptography-43[${PYTHON_USEDEP}]
+ <dev-python/pyscard-3[${PYTHON_USEDEP}]
+ examples? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ docinto examples
+ dodoc -r "${S}"/examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+}