summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-pymongo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-pymongo')
-rw-r--r--dev-python/flask-pymongo/Manifest2
-rw-r--r--dev-python/flask-pymongo/files/docbuild.patch16
-rw-r--r--dev-python/flask-pymongo/flask-pymongo-0.3.0.ebuild45
-rw-r--r--dev-python/flask-pymongo/flask-pymongo-0.3.1.ebuild50
-rw-r--r--dev-python/flask-pymongo/metadata.xml13
5 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/flask-pymongo/Manifest b/dev-python/flask-pymongo/Manifest
new file mode 100644
index 000000000000..b4f8dbd61700
--- /dev/null
+++ b/dev-python/flask-pymongo/Manifest
@@ -0,0 +1,2 @@
+DIST flask-pymongo-0.3.0.tar.gz 21019 SHA256 b1ab5c38f43a8f7ae3e981fb8e0a5d58fb47b066ba0c1b647738e68690f62473 SHA512 669e2c2df4c3378aec0a9f401120ceee2bfb0452a093beca6e7adaffd764bfe0a90a5e5b82d0945933693c3c179f3a0bf56cd4a2e03ab0522065eb650550ff44 WHIRLPOOL 4563628d4d77dbcc9253520636875774655865ba9510b955afe5509da3e9e872b97355649b61ad59e4693c018216f82b7757129d32c112cb95212bfa0c703c23
+DIST flask-pymongo-0.3.1.tar.gz 21712 SHA256 21f807bd6c46d16203a9bb056a01516d6bd437a8a34b28ae38f345c3d16e9dc9 SHA512 cae90061b25187ebdd321af584fc7d6a8497c373dcde63641c60e6c77c985740f613043fd9efffe011486178cd3b7ff8b770ab9ccd5a37cadbfd9fd2ddbae4b5 WHIRLPOOL 8303233be2fff47fcccf363bdbebd29522fac2e00dc17dd90af275a7be77edb325772cb21c3e2cb4d7fca7eb64176c9b231c09b7c8af5a7dadc41279a5398d36
diff --git a/dev-python/flask-pymongo/files/docbuild.patch b/dev-python/flask-pymongo/files/docbuild.patch
new file mode 100644
index 000000000000..232a5b8fc6c8
--- /dev/null
+++ b/dev-python/flask-pymongo/files/docbuild.patch
@@ -0,0 +1,16 @@
+Avoid un-needed d'loading
+diff -ur Flask-PyMongo-0.2.1.orig/docs/conf.py Flask-PyMongo-0.2.1/docs/conf.py
+--- docs/conf.py 2012-12-23 00:52:16.000000000 +0800
++++ docs/conf.py 2013-06-10 01:26:28.430485499 +0800
+@@ -247,11 +247,3 @@
+
+ # How to display URL addresses: 'footnote', 'no', or 'inline'.
+ #texinfo_show_urls = 'footnote'
+-
+-
+-# Example configuration for intersphinx: refer to the Python standard library.
+-intersphinx_mapping = {
+- 'python': ('http://docs.python.org/', None),
+- 'flask': ('http://flask.pocoo.org/docs/', None),
+- 'pymongo': ('http://api.mongodb.org/python/current/', None),
+-}
diff --git a/dev-python/flask-pymongo/flask-pymongo-0.3.0.ebuild b/dev-python/flask-pymongo/flask-pymongo-0.3.0.ebuild
new file mode 100644
index 000000000000..4f80d54e592a
--- /dev/null
+++ b/dev-python/flask-pymongo/flask-pymongo-0.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="Flask-PyMongo"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PyMongo support for Flask"
+HOMEPAGE="http://pypi.python.org/pypi/Flask-PyMongo"
+SRC_URI="https://github.com/dcrosta/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-2.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/docbuild.patch )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # fix me
+ nosetests tests/{test_url_converter.py,test_wrappers.py} || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-pymongo/flask-pymongo-0.3.1.ebuild b/dev-python/flask-pymongo/flask-pymongo-0.3.1.ebuild
new file mode 100644
index 000000000000..93a03fe86327
--- /dev/null
+++ b/dev-python/flask-pymongo/flask-pymongo-0.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="Flask-PyMongo"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PyMongo support for Flask"
+HOMEPAGE="http://pypi.python.org/pypi/Flask-PyMongo"
+SRC_URI="https://github.com/dcrosta/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/flask-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-2.4[${PYTHON_USEDEP}]
+ <dev-python/pymongo-3.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/docbuild.patch )
+
+python_prepare_all() {
+ # Req'd to avoid file collisions
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+# Testsuite appears to require a running local instance of a pymongo server
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-pymongo/metadata.xml b/dev-python/flask-pymongo/metadata.xml
new file mode 100644
index 000000000000..024aa03937da
--- /dev/null
+++ b/dev-python/flask-pymongo/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>ultrabug@gentoo.org</email>
+ <name>Alexys Jacob</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">Flask-PyMongo</remote-id>
+ <remote-id type="github">dcrosta/flask-pymongo</remote-id>
+ </upstream>
+</pkgmetadata>