summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-20 06:37:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-20 06:37:31 +0200
commit79cc4e1e0866e8164275a8a993af18639fe032ba (patch)
tree395ef87563f23dc2dd735da644f48a18f77f8a5c /dev-python/google-api-core
parentdev-python/Levenshtein: Bump to 0.26.0 (diff)
downloadgentoo-79cc4e1e0866e8164275a8a993af18639fe032ba.tar.gz
gentoo-79cc4e1e0866e8164275a8a993af18639fe032ba.tar.bz2
gentoo-79cc4e1e0866e8164275a8a993af18639fe032ba.zip
dev-python/google-api-core: Bump to 2.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-core')
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.20.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index c9a3baed0c85..6ff657545aeb 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1 +1,2 @@
DIST python-api-core-2.19.2.gh.tar.gz 212969 BLAKE2B 6ecb63085b9108cb0755dc3bdd31d328de948ede85e2f1e62dae92bd9c12d6d90d4ef24f57a7a953567e6f9e8d105ffbde8bd99d8a42081190f95f2a48b6504c SHA512 76a890ebaaecfd4d913e4e1d3d370e81e655eb5e8192a10292a7a792f6a9287dde7dea43f27a70edcc7430f71346e52f2719393b54cfd7c4223eeba3c28d37e4
+DIST python-api-core-2.20.0.gh.tar.gz 216778 BLAKE2B a6873f5bb07928933ab5dc04bd3e02ffab06c38c70661ff2da7e6ca183e49a0a4995b4b672f188ede14e416a953d3385ac564dd02ef643bd9cc63d0c16063e23 SHA512 4dd369da408acc15e54a1b7fd13cc2747d5a3ae3812cf42a3c0ec4a93245cc0f7c7cbef456ff19655e8d2d22955aec7369a295faef81cc4ea268c419ca62ef03
diff --git a/dev-python/google-api-core/google-api-core-2.20.0.ebuild b/dev-python/google-api-core/google-api-core-2.20.0.ebuild
new file mode 100644
index 000000000000..61fa5cb4fa0b
--- /dev/null
+++ b/dev-python/google-api-core/google-api-core-2.20.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=python-api-core-${PV}
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="
+ https://github.com/googleapis/python-api-core/
+ https://pypi.org/project/google-api-core/
+ https://googleapis.dev/python/google-api-core/latest/index.html
+"
+SRC_URI="
+ https://github.com/googleapis/python-api-core/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/googleapis-common-protos-1.56.2[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
+ >=dev-python/proto-plus-1.22.3[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # failing due to missing grpcio-status
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
+ tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
+ tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
+ tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
+)
+
+python_test() {
+ rm -rf google || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio tests
+}