summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-07 12:59:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-07 13:29:51 +0100
commit103018f751591406365583baf14445473b263543 (patch)
treedd5ec50fb9dc460350c1a69aef7d08c3422cd4db /dev-python/identify
parentdev-util/cmake: add 3.28.0 (diff)
downloadgentoo-103018f751591406365583baf14445473b263543.tar.gz
gentoo-103018f751591406365583baf14445473b263543.tar.bz2
gentoo-103018f751591406365583baf14445473b263543.zip
dev-python/identify: Bump to 2.5.33
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.33.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 9fda44126e9f..30d8007f4f93 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1,2 +1,3 @@
DIST identify-2.5.31.gh.tar.gz 101612 BLAKE2B 1b74bf8b352cc0f6f0051ccdba192515a1436bfa9e41f971ac929e356737c586c48d1684b982d468e42489e97913a46357dc705a766066c9edb6e6d43f1bbf89 SHA512 00116339c82625087c58a7393bf88800608a152a56fd03b13d1e9ff8c404fa9cfc6ac6824ac1b6eadba572f0e13fb0010789bcdefb7f551b15df4c3de98f77bc
DIST identify-2.5.32.gh.tar.gz 101673 BLAKE2B a24c0df85c482fbc04adce0be258aa96ffa387eb569365fcdf589cf5fc4d3823ade3c60a0e2e9df65610506bc0d74c532b9964af1fea367191e3c4572e62388f SHA512 104326e2c1529c89425eeaf738a65bf9fc7f2dfa99e7aae18b33c8250aa34f3ead0371dbd2dad9253100de59f618c6c8d3c033f406eec179f1dcce47fe43fc36
+DIST identify-2.5.33.gh.tar.gz 101683 BLAKE2B 0b66bc611e5ba01029c2d8aa13146025eb68296793a148eafecc7584d3d68d77d8ebae67306e8fc64e7265ab673fa4852497f25b9ba73e895c61e4f4ec2997e2 SHA512 cb3cc2064814b6694122040dc1be31f09bbddaf988f15425717d5561f175b216e62f4449cff5d697a8d612a48513e97446973bba42f376cdcfad1d93d1e14cf7
diff --git a/dev-python/identify/identify-2.5.33.ebuild b/dev-python/identify/identify-2.5.33.ebuild
new file mode 100644
index 000000000000..906b58d7a709
--- /dev/null
+++ b/dev-python/identify/identify-2.5.33.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest