summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-09 13:58:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-09 14:22:08 +0200
commit8931d40d0a7d7d4f7664beed61de72f95a3a5e36 (patch)
tree677104343aec6beb47ec6d1704994937f3a902ca /dev-python/iso8601/iso8601-2.0.0.ebuild
parentsys-apps/grep: Stabilize 3.11 arm, #908100 (diff)
downloadgentoo-8931d40d0a7d7d4f7664beed61de72f95a3a5e36.tar.gz
gentoo-8931d40d0a7d7d4f7664beed61de72f95a3a5e36.tar.bz2
gentoo-8931d40d0a7d7d4f7664beed61de72f95a3a5e36.zip
dev-python/iso8601: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/iso8601/iso8601-2.0.0.ebuild')
-rw-r--r--dev-python/iso8601/iso8601-2.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/iso8601/iso8601-2.0.0.ebuild b/dev-python/iso8601/iso8601-2.0.0.ebuild
new file mode 100644
index 000000000000..06e35ce294fe
--- /dev/null
+++ b/dev-python/iso8601/iso8601-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple module to parse ISO 8601 dates"
+HOMEPAGE="
+ https://github.com/micktwomey/pyiso8601/
+ https://pypi.org/project/iso8601/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest