summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-30 05:06:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-30 05:06:54 +0200
commitd49bba46f56cba23200ecce822b0571702d9601b (patch)
tree212b7822a5ce5236d21e336ebf5c943fc40fd113 /dev-python/jupyter-client
parentdev-python/pydantic-core: Bump to 2.7.0 (diff)
downloadgentoo-d49bba46f56cba23200ecce822b0571702d9601b.tar.gz
gentoo-d49bba46f56cba23200ecce822b0571702d9601b.tar.bz2
gentoo-d49bba46f56cba23200ecce822b0571702d9601b.zip
dev-python/jupyter-client: Bump to 8.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-client')
-rw-r--r--dev-python/jupyter-client/Manifest1
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.3.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
index 7e74dbad2c65..017faf3fca70 100644
--- a/dev-python/jupyter-client/Manifest
+++ b/dev-python/jupyter-client/Manifest
@@ -1 +1,2 @@
DIST jupyter_client-8.3.0.tar.gz 335973 BLAKE2B dd4b60994f5c2ba19d41f87dbbee1291e85595908e5b1fce77876d8164bc21bd65b257a65b333e2e3277fff66869d445fcd87c3c1a16166fa71da24d26b1e96e SHA512 2348cf67344cb9bbb9b020ef5570f5ca354c8acb00b9fb0d148b9419ec2efb922b1364ed3c2c2429ad66548af5dd90f232be1d56728ef09bd833312f13c07f77
+DIST jupyter_client-8.3.1.tar.gz 337007 BLAKE2B fdb0535ccda1ca13e2ead09c6df9f30c8c7d258dbfa4882a758b3923fd5bdf6afa80859f941bcc3e1a602de31c6ceef06b7a5d360d64ceab34e40de65dc65174 SHA512 ce600985ed9d36d4a96bbed6142b46988d46ea468d8f266fd3c9a7357f60d5e2a9bddb11c912a3c137079322e4363b975c4b43b1a53e65b5d649d367a098a52d
diff --git a/dev-python/jupyter-client/jupyter-client-8.3.1.ebuild b/dev-python/jupyter-client/jupyter-client-8.3.1.ebuild
new file mode 100644
index 000000000000..13fe78be87b6
--- /dev/null
+++ b/dev-python/jupyter-client/jupyter-client-8.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter protocol implementation and client libraries"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_client/
+ https://pypi.org/project/jupyter-client/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
+ ' 3.{8,9})
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
+ >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO: times out
+ tests/test_client.py::TestAsyncKernelClient::test_input_request
+ # TODO
+ tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
+)