summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-09 09:44:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-09 09:46:38 +0200
commit3160ae7277466365bdf4e428131bb99c9cc3618f (patch)
tree3a2da8cd8faa4be1be2ec5247259644295b9972f /dev-python/jupyter_core
parentsys-libs/glibc: always use NM and READELF for default ABI (diff)
downloadgentoo-3160ae7277466365bdf4e428131bb99c9cc3618f.tar.gz
gentoo-3160ae7277466365bdf4e428131bb99c9cc3618f.tar.bz2
gentoo-3160ae7277466365bdf4e428131bb99c9cc3618f.zip
dev-python/jupyter_core: Bump to 4.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter_core')
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.6.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index 19d101e4e616..5032c8f9ad89 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1 +1,2 @@
DIST jupyter_core-4.6.1.tar.gz 66693 BLAKE2B f4338a015ac4b3e0a7cd2497a660bfca0deb96ffa2371fa9c72656f8a68b6f80fe5d494be79c8fdccbcb51f3d9122fd7d4b3e36864d38e7da1c5029c6b1aa24d SHA512 baf0c5db4f78a3cee83940ace80b48ba308c47eeafcf584120b8ba82768c15448fb789ec5b9ac8d541cbd1bfdd47a988f79130675c5943a67d3135d428b43cbe
+DIST jupyter_core-4.6.3.tar.gz 67305 BLAKE2B 7c6a32bd8ce773b7bc4156eabf75597112716632179736b19be4b0e73eba7c5c67a0c9d2d141b952d72b68aff826227b0004a3bc9f3b286b68eb1375f2316bdb SHA512 3c7370c24a4cf53c9747e9e411852d207c0c7035809dab7cb018ccb53e19208df25ad4f728531e47f3a42c4d9694c3e1ed7b03133de23bcbdeb346c319f5f51f
diff --git a/dev-python/jupyter_core/jupyter_core-4.6.3.ebuild b/dev-python/jupyter_core/jupyter_core-4.6.3.ebuild
new file mode 100644
index 000000000000..ba4f8a20402a
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.6.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest
+
+src_prepare() {
+ # rely on imports working without PYTHONPATH
+ sed -e 's:test_not_on_path:_&:' \
+ -e 's:test_path_priority:_&:' \
+ -i jupyter_core/tests/test_command.py || die
+
+ distutils-r1_src_prepare
+}