summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-15 05:55:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-15 05:55:28 +0100
commit6a01ffe1131ee469af2dda49e8c472666c5bc5e6 (patch)
tree8d08e54d196f3650d6d7b0ba4030d2b7ed2c3d56 /dev-python/markdown
parentdev-python/sqlglot: Bump to 22.5.0 (diff)
downloadgentoo-6a01ffe1131ee469af2dda49e8c472666c5bc5e6.tar.gz
gentoo-6a01ffe1131ee469af2dda49e8c472666c5bc5e6.tar.bz2
gentoo-6a01ffe1131ee469af2dda49e8c472666c5bc5e6.zip
dev-python/markdown: Bump to 3.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown')
-rw-r--r--dev-python/markdown/Manifest1
-rw-r--r--dev-python/markdown/markdown-3.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/markdown/Manifest b/dev-python/markdown/Manifest
index 17944e166b4e..0218c2ae8e1d 100644
--- a/dev-python/markdown/Manifest
+++ b/dev-python/markdown/Manifest
@@ -1,2 +1,3 @@
DIST Markdown-3.5.1.tar.gz 348575 BLAKE2B 4400158e11e17c3ae5714928ccc5a964d76459a6ff7b5721f246e58bff31828f6eef5ef0928a82c0e5bd7776a6fc55457634870e79443893bd2a529560ca900d SHA512 72771300bded3a12b0f1addfcdb124c8e12d3b42672c62b92b7565a03d8ba108fe9d156a59c1783295059a11e6e2d312ec4f60de2bc6c0ee7b853c0a56e2e97c
DIST Markdown-3.5.2.tar.gz 349398 BLAKE2B 7bf9775883f4f24254d1939ffa49555682c11765a07790f6274ba120073ac512b8a319680edb80f9c4a20bf8c8b2e2deb58afd022a791cd6a03e1c95ba605e2b SHA512 a112620162cb0764848dbe766bd23df6b7220ec3db6eb60d5663757092300c5c6abb9af6a412280fc3f59e617263c3abf0ed4a969eebacd3e964228525165f24
+DIST Markdown-3.6.tar.gz 354715 BLAKE2B bd8cb489fb20c0d8416361c435113a6057ced5f4baceba8665e1afc70efcbd6a52153785a436c94ff9d68571d668b7898c6717851b10814d89e46e2b9daba3e7 SHA512 a523f75ea72fa71f4f0f1a59523bb1a6c5c7605ba5a0be4dc37aa5bd5c87e32563f5253404485c99c13caa27501c9003aea524154a7999a22e6497829492b997
diff --git a/dev-python/markdown/markdown-3.6.ebuild b/dev-python/markdown/markdown-3.6.ebuild
new file mode 100644
index 000000000000..bbd10a132ae4
--- /dev/null
+++ b/dev-python/markdown/markdown-3.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+ https://python-markdown.github.io/
+ https://pypi.org/project/Markdown/
+ https://github.com/Python-Markdown/markdown/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc"
+
+BDEPEND="
+ test? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytidylib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ use doc && dodoc -r docs/
+
+ distutils-r1_python_install_all
+}