summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-21 18:03:26 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-21 19:15:15 -0800
commit327a1a4ad4a35ce5e36c688cddfdf7accf162876 (patch)
treea790f29d67a9fd1a8fd0f72425a80d8edfd911bd /dev-python/munch
parentdev-python/psutil: Version bump to 5.6.5, add py38, enable tests (diff)
downloadgentoo-327a1a4ad4a35ce5e36c688cddfdf7accf162876.tar.gz
gentoo-327a1a4ad4a35ce5e36c688cddfdf7accf162876.tar.bz2
gentoo-327a1a4ad4a35ce5e36c688cddfdf7accf162876.zip
dev-python/munch: Version bump to 2.5.0, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/munch')
-rw-r--r--dev-python/munch/Manifest1
-rw-r--r--dev-python/munch/files/munch-2.5.0-pbrectomy.patch17
-rw-r--r--dev-python/munch/files/munch-2.5.0-revert-pbr.patch39
-rw-r--r--dev-python/munch/munch-2.5.0.ebuild32
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/munch/Manifest b/dev-python/munch/Manifest
index 653102ab3be6..b8e3f574e94d 100644
--- a/dev-python/munch/Manifest
+++ b/dev-python/munch/Manifest
@@ -1,3 +1,4 @@
DIST munch-2.1.1.tar.gz 6565 BLAKE2B 81d0ea79df9934ec4fcd4d650dde6822258b3dbaaee8b114cb445219c89b76e40c7aaddd06306f9ba585081b556d7fa32d2e002de8bf5c071b0fe361092cd18b SHA512 5ffd78b1e062f71c73047a03949e6cddcd0eeae3a0ccccf36687140d12de9eb29161d2891a0fa2f1e70dfbc2b33c4ddab5d8a3611990718330c280ea769e85c0
DIST munch-2.2.0.tar.gz 7108 BLAKE2B c01635adbcc1083dd539317f6619ad15bb654d1f5114d3b5f5253bbd1bf92a860d3b030233f85878780d33ca171bd08c44b37c9bdb538e4be868704861c4372f SHA512 420b9fe4486aac00b3a0d747995df46bb3fc72a5bcfa4fadbad3e3a50431493f69ca76294ae541042aaabec6e01794f8f3c9c03a5c0d6058e730dccb62e42e45
DIST munch-2.3.2.tar.gz 7598 BLAKE2B 0ff607c4821b675bb0710e185c82135ba031e2ad0e18aae07f8736e102ee73c53a6977155f250ff20e26e87671f8a20ed7bac625bb96625017be047704f63bc6 SHA512 7cbcd79b9506940f88a2090649e5ab6678164b468ed04feebeab8f85c9af861a1a8012aaafc869755c3c7957feefb231bc15426c382c014e82e9b806a879b8e7
+DIST munch-2.5.0.tar.gz 17015 BLAKE2B 17af271ae082a6e5f91781ba48a440f11cbe85ecb81d47ee2bc51910307080e3ba6c95e99e7475534400b2915a86d8f853bc65d419c3d3b7138bf021e66de25c SHA512 7eca31111f40782a19b49535322bc56d723022d52b0842c4beff512f32fa415a6c75851eb84950358cb6a11693095cafe56364028e48385b11135de414edca21
diff --git a/dev-python/munch/files/munch-2.5.0-pbrectomy.patch b/dev-python/munch/files/munch-2.5.0-pbrectomy.patch
new file mode 100644
index 000000000000..13121c345b80
--- /dev/null
+++ b/dev-python/munch/files/munch-2.5.0-pbrectomy.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index 31f229c..62e1ad6 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,7 @@
+-from setuptools import setup
++from setuptools import setup, find_packages
+
+
+ setup(
+- setup_requires=['pbr>=3.0', 'setuptools>=17.1'],
+- pbr=True,
+- long_description_content_type='text/markdown; charset=UTF-8',
+- keywords=['munch', 'dict', 'mapping', 'container', 'collection'],
++ find_packages(exclude=['tests']),
++ version="%VERSION%"
+ )
diff --git a/dev-python/munch/files/munch-2.5.0-revert-pbr.patch b/dev-python/munch/files/munch-2.5.0-revert-pbr.patch
new file mode 100644
index 000000000000..450020cc2c19
--- /dev/null
+++ b/dev-python/munch/files/munch-2.5.0-revert-pbr.patch
@@ -0,0 +1,39 @@
+diff --git a/setup.py b/setup.py
+index 31f229c..9046e38 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,9 +1,29 @@
+-from setuptools import setup
+-
++from setuptools import setup, find_packages
+
+ setup(
+- setup_requires=['pbr>=3.0', 'setuptools>=17.1'],
+- pbr=True,
+- long_description_content_type='text/markdown; charset=UTF-8',
++ name="munch",
++ version=__version__,
++ description="A dot-accessible dictionary (a la JavaScript objects).",
++ url="http://github.com/Infinidat/munch",
++ author="Rotem Yaari",
++ author_email="vmalloc@gmail.com",
++ install_requires=[
++ 'six',
++ ],
++ packages=find_packages(exclude=["tests"]),
+ keywords=['munch', 'dict', 'mapping', 'container', 'collection'],
++ classifiers=[
++ 'Development Status :: 5 - Production/Stable',
++ 'Intended Audience :: Developers',
++ 'Operating System :: OS Independent',
++ 'Programming Language :: Python',
++ "Programming Language :: Python :: 2.7",
++ "Programming Language :: Python :: 3.5",
++ "Programming Language :: Python :: 3.6",
++ 'Topic :: Software Development',
++ 'Topic :: Software Development :: Libraries',
++ 'Topic :: Utilities',
++ 'License :: OSI Approved :: MIT License',
++ ],
++ license='MIT',
+ )
diff --git a/dev-python/munch/munch-2.5.0.ebuild b/dev-python/munch/munch-2.5.0.ebuild
new file mode 100644
index 000000000000..afa3466ae03e
--- /dev/null
+++ b/dev-python/munch/munch-2.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A dot-accessible dictionary (a la JavaScript objects)"
+HOMEPAGE="https://github.com/Infinidat/munch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/munch-2.5.0-revert-pbr.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ sed -i "s:__version__:'${PV}':" setup.py || die
+}