summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-08 15:52:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-08 16:39:36 +0100
commitf257496dc3a3d13f31ea5593f43065194a43ff6f (patch)
tree05ec94e74ab45aec3348e1f5eeec5ddecdf4cbb1 /dev-python/paginate
parentmedia-gfx/libredwg: add 0.12.5.6564 (diff)
downloadgentoo-f257496dc3a3d13f31ea5593f43065194a43ff6f.tar.gz
gentoo-f257496dc3a3d13f31ea5593f43065194a43ff6f.tar.bz2
gentoo-f257496dc3a3d13f31ea5593f43065194a43ff6f.zip
dev-python/paginate: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paginate')
-rw-r--r--dev-python/paginate/paginate-0.5.6.ebuild19
1 files changed, 18 insertions, 1 deletions
diff --git a/dev-python/paginate/paginate-0.5.6.ebuild b/dev-python/paginate/paginate-0.5.6.ebuild
index 6da012715c15..5f8fe5a3f93a 100644
--- a/dev-python/paginate/paginate-0.5.6.ebuild
+++ b/dev-python/paginate/paginate-0.5.6.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1
@@ -23,3 +23,20 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv x86"
distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # these tests assume that dict is not sliceable
+ # https://github.com/Pylons/paginate/issues/19
+ tests/test_paginate.py::test_wrong_collection
+ tests/test_paginate.py::TestCollectionTypes::test_unsliceable_sequence3
+ )
+ ;;
+ esac
+
+ epytest
+}