summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-30 15:51:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-30 16:16:10 +0100
commitd88de0338fd819c835a044ba783db44ef0ff2bd1 (patch)
treeaae9ed3905a1ac5157500af197122f3030474e63 /dev-python/pyasn1-modules
parentdev-python/pyasn1: Bump to 0.6.1 (diff)
downloadgentoo-d88de0338fd819c835a044ba783db44ef0ff2bd1.tar.gz
gentoo-d88de0338fd819c835a044ba783db44ef0ff2bd1.tar.bz2
gentoo-d88de0338fd819c835a044ba783db44ef0ff2bd1.zip
dev-python/pyasn1-modules: Bump to 0.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyasn1-modules')
-rw-r--r--dev-python/pyasn1-modules/Manifest1
-rw-r--r--dev-python/pyasn1-modules/files/pyasn1-modules-0.4.1-test.patch168
-rw-r--r--dev-python/pyasn1-modules/pyasn1-modules-0.4.1.ebuild37
3 files changed, 206 insertions, 0 deletions
diff --git a/dev-python/pyasn1-modules/Manifest b/dev-python/pyasn1-modules/Manifest
index 7dca03942c77..62a78b1f1b1f 100644
--- a/dev-python/pyasn1-modules/Manifest
+++ b/dev-python/pyasn1-modules/Manifest
@@ -1 +1,2 @@
DIST pyasn1_modules-0.4.0.tar.gz 307859 BLAKE2B 7808c3ad72cda2292fa358a066cb401884a785281c5ba3c28ec5cbf1a7c7408031ff1018f4e0c4e53ac227a6b7082bb5572216ab12074c90f0a3159330ec3f35 SHA512 d28cbb44788b3a33b9da807d273a6afab38ff420e8ce1264a9ebc68beb003f9ac9673210a5eb829d17ed1ae01798f856a0409dcbcd1a17b489c767d4b11467d3
+DIST pyasn1_modules-0.4.1.tar.gz 310028 BLAKE2B dcffd13196982fb9f4808a789252b9c9910bff3c3eb3e852d13cf1e1285bac4f2900dc62698d9929da4ff882e5d823f2e5290fecd1488e5b61d04c62fe24e2ec SHA512 d3716cafbfe940c5415cb59073897cd15d69b9723064ba581b7d573fe9a0fad9872d88517fe03b0db5b4fa93f8cd3254372e71d60ff5975013c97409b6c22d1d
diff --git a/dev-python/pyasn1-modules/files/pyasn1-modules-0.4.1-test.patch b/dev-python/pyasn1-modules/files/pyasn1-modules-0.4.1-test.patch
new file mode 100644
index 000000000000..979e5f8d9c78
--- /dev/null
+++ b/dev-python/pyasn1-modules/files/pyasn1-modules-0.4.1-test.patch
@@ -0,0 +1,168 @@
+From 079c176eb00ed7352c9696efa12a0577beeecd71 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <mail@heiko-becker.de>
+Date: Wed, 25 Sep 2024 22:38:42 +0200
+Subject: [PATCH] Stop using pyasn1.compat.octets
+
+It was removed from pyasn1 in
+https://github.com/pyasn1/pyasn1/commit/6f770ba886a8931c35cb090a5c3a6d67f5a41bd9
+
+Fixes #19.
+---
+ tests/test_pem.py | 3 +--
+ tests/test_rfc3770.py | 3 +--
+ tests/test_rfc4073.py | 3 +--
+ tests/test_rfc4334.py | 3 +--
+ tests/test_rfc5755.py | 3 +--
+ tests/test_rfc6032.py | 7 +++----
+ tests/test_rfc6120.py | 1 -
+ 7 files changed, 8 insertions(+), 15 deletions(-)
+
+diff --git a/tests/test_pem.py b/tests/test_pem.py
+index dbcca5a7..e0fe334d 100644
+--- a/tests/test_pem.py
++++ b/tests/test_pem.py
+@@ -7,7 +7,6 @@
+ import sys
+ import unittest
+
+-from pyasn1.compat.octets import ints2octs
+ from pyasn1_modules import pem
+
+
+@@ -93,7 +92,7 @@ def testReadBase64fromText(self):
+ 24, 102, 241, 236, 50
+ ]
+
+- self.assertEqual(ints2octs(expected), binary)
++ self.assertEqual(bytes(expected), binary)
+
+
+ suite = unittest.TestLoader().loadTestsFromModule(sys.modules[__name__])
+diff --git a/tests/test_rfc3770.py b/tests/test_rfc3770.py
+index 667ab249..93d40932 100644
+--- a/tests/test_rfc3770.py
++++ b/tests/test_rfc3770.py
+@@ -10,7 +10,6 @@
+
+ from pyasn1.codec.der.decoder import decode as der_decoder
+ from pyasn1.codec.der.encoder import encode as der_encoder
+-from pyasn1.compat.octets import str2octs
+
+ from pyasn1_modules import pem
+ from pyasn1_modules import rfc5480
+@@ -79,7 +78,7 @@ def testOpenTypes(self):
+ self.assertEqual(extn['extnValue'], der_encoder(extnValue))
+
+ if extn['extnID'] == rfc3770.id_pe_wlanSSID:
+- self.assertIn(str2octs('Example'), extnValue)
++ self.assertIn(b'Example', extnValue)
+
+ if extn['extnID'] == rfc5280.id_ce_extKeyUsage:
+ self.assertIn(rfc3770.id_kp_eapOverLAN, extnValue)
+diff --git a/tests/test_rfc4073.py b/tests/test_rfc4073.py
+index 4bd5e5f7..3b516ccb 100644
+--- a/tests/test_rfc4073.py
++++ b/tests/test_rfc4073.py
+@@ -10,7 +10,6 @@
+
+ from pyasn1.codec.der.decoder import decode as der_decoder
+ from pyasn1.codec.der.encoder import encode as der_encoder
+-from pyasn1.compat.octets import str2octs
+
+ from pyasn1_modules import pem
+ from pyasn1_modules import rfc2634
+@@ -131,7 +130,7 @@ def testOpenTypes(self):
+
+ self.assertIn(next_ci['contentType'], rfc5652.cmsContentTypesMap)
+ self.assertEqual(rfc5652.id_data, next_ci['contentType'])
+- self.assertIn(str2octs('Content-Type: text'), next_ci['content'])
++ self.assertIn(b'Content-Type: text', next_ci['content'])
+
+ for attr in ci['content']['attrs']:
+ self.assertIn(attr['attrType'], rfc5652.cmsAttributesMap)
+diff --git a/tests/test_rfc4334.py b/tests/test_rfc4334.py
+index 9ba5fdf3..e180d676 100644
+--- a/tests/test_rfc4334.py
++++ b/tests/test_rfc4334.py
+@@ -10,7 +10,6 @@
+
+ from pyasn1.codec.der.decoder import decode as der_decoder
+ from pyasn1.codec.der.encoder import encode as der_encoder
+-from pyasn1.compat.octets import str2octs
+
+ from pyasn1_modules import pem
+ from pyasn1_modules import rfc5280
+@@ -67,7 +66,7 @@ def testOpenTypes(self):
+ self.assertEqual(extn['extnValue'], der_encoder(extnValue))
+
+ if extn['extnID'] == rfc4334.id_pe_wlanSSID:
+- self.assertIn( str2octs('Example'), extnValue)
++ self.assertIn(b'Example', extnValue)
+
+ if extn['extnID'] == rfc5280.id_ce_extKeyUsage:
+ self.assertIn(rfc4334.id_kp_eapOverLAN, extnValue)
+diff --git a/tests/test_rfc5755.py b/tests/test_rfc5755.py
+index cf4a05fa..46908e23 100644
+--- a/tests/test_rfc5755.py
++++ b/tests/test_rfc5755.py
+@@ -10,7 +10,6 @@
+
+ from pyasn1.codec.der.decoder import decode as der_decoder
+ from pyasn1.codec.der.encoder import encode as der_encoder
+-from pyasn1.compat.octets import str2octs
+
+ from pyasn1_modules import pem
+ from pyasn1_modules import rfc5280
+@@ -85,7 +84,7 @@ def testOpenTypes(self):
+ count += 1
+ if attr['type'] == rfc5755.id_aca_authenticationInfo:
+ self.assertEqual(
+- str2octs('password'), attr['values'][0]['authInfo'])
++ b'password', attr['values'][0]['authInfo'])
+
+ self.assertEqual(5, count)
+
+diff --git a/tests/test_rfc6032.py b/tests/test_rfc6032.py
+index 287bad89..2327416d 100644
+--- a/tests/test_rfc6032.py
++++ b/tests/test_rfc6032.py
+@@ -10,7 +10,6 @@
+
+ from pyasn1.codec.der.decoder import decode as der_decoder
+ from pyasn1.codec.der.encoder import encode as der_encoder
+-from pyasn1.compat.octets import str2octs
+
+ from pyasn1_modules import pem
+ from pyasn1_modules import rfc5652
+@@ -64,7 +63,7 @@ def testDerCodec(self):
+ self.assertFalse(rest)
+ self.assertTrue(keyid.prettyPrint())
+ self.assertEqual(attrVal0, der_encoder(keyid))
+- self.assertEqual(str2octs('ptf-kdc-812374'), keyid)
++ self.assertEqual(b'ptf-kdc-812374', keyid)
+
+ def testOpenTypes(self):
+ substrate = pem.readBase64fromText(self.encrypted_key_pkg_pem_text)
+@@ -86,8 +85,8 @@ def testOpenTypes(self):
+ self.assertNotEqual('0x', attr['attrValues'][0].prettyPrint()[:2])
+
+ if attr['attrType'] == rfc6032.id_aa_KP_contentDecryptKeyID:
+- self.assertEqual(str2octs(
+- 'ptf-kdc-812374'), attr['attrValues'][0])
++ self.assertEqual(
++ b'ptf-kdc-812374', attr['attrValues'][0])
+
+
+ suite = unittest.TestLoader().loadTestsFromModule(sys.modules[__name__])
+diff --git a/tests/test_rfc6120.py b/tests/test_rfc6120.py
+index bdedab8c..a6217454 100644
+--- a/tests/test_rfc6120.py
++++ b/tests/test_rfc6120.py
+@@ -10,7 +10,6 @@
+
+ from pyasn1.codec.der.decoder import decode as der_decoder
+ from pyasn1.codec.der.encoder import encode as der_encoder
+-from pyasn1.compat.octets import str2octs
+
+ from pyasn1_modules import pem
+ from pyasn1_modules import rfc5280
diff --git a/dev-python/pyasn1-modules/pyasn1-modules-0.4.1.ebuild b/dev-python/pyasn1-modules/pyasn1-modules-0.4.1.ebuild
new file mode 100644
index 000000000000..ebaaaebce833
--- /dev/null
+++ b/dev-python/pyasn1-modules/pyasn1-modules-0.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pyasn1 modules"
+HOMEPAGE="
+ https://pypi.org/project/pyasn1-modules/
+ https://github.com/pyasn1/pyasn1-modules/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ <dev-python/pyasn1-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.4.6[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ # https://github.com/pyasn1/pyasn1-modules/pull/22
+ "${FILESDIR}/${P}-test.patch"
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /usr/share/${P}
+ doins -r tools
+}