summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-27 19:59:40 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-27 20:07:49 +0200
commitd2a9def05500f4e6f403ff56ad9cc54aede11ee7 (patch)
tree26cc3740e2d737fb5be38b0e554634b66393eb0d /dev-python/pycparser/pycparser-2.18-r1.ebuild
parentnet-libs/uhttpmock: version bump 0.5.0 → 0.5.1 (diff)
downloadgentoo-d2a9def05500f4e6f403ff56ad9cc54aede11ee7.tar.gz
gentoo-d2a9def05500f4e6f403ff56ad9cc54aede11ee7.tar.bz2
gentoo-d2a9def05500f4e6f403ff56ad9cc54aede11ee7.zip
dev-python/pycparser: Enforce regenerating tables
Remove the pregenerated tables provided in the distfile to force regenerating them. Generate the tables for every Python implementation separately to avoid incompatibility/underoptimization problems (tables built by Python 3.5+ are incompatible with older Python versions that have 100 group-in-regex limit).
Diffstat (limited to 'dev-python/pycparser/pycparser-2.18-r1.ebuild')
-rw-r--r--dev-python/pycparser/pycparser-2.18-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pycparser/pycparser-2.18-r1.ebuild b/dev-python/pycparser/pycparser-2.18-r1.ebuild
new file mode 100644
index 000000000000..3fb094f6ff3f
--- /dev/null
+++ b/dev-python/pycparser/pycparser-2.18-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="C parser and AST generator written in Python"
+HOMEPAGE="https://github.com/eliben/pycparser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # remove the original files to guarantee their regen
+ rm pycparser/{c_ast,lextab,yacctab}.py || die
+
+ # kill sys.path manipulations to force the tests to use built files
+ sed -i -e '/sys\.path/d' tests/*.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # note: tables built by py3.5+ are incompatible with older versions
+ # because of 100 group limit of 're' module -- just generate them
+ # separately optimized for each target instead
+ pushd "${BUILD_DIR}"/lib/pycparser > /dev/null || die
+ "${PYTHON}" _build_tables.py || die
+ popd > /dev/null || die
+}
+
+python_test() {
+ # change workdir to avoid '.' import
+ nosetests -v -w tests || die
+}