summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-02 06:20:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-02 06:30:31 +0100
commit1b74b3ec2f10dc2e62780464154cf44f13db21a0 (patch)
treef8e9e0fe2cc4ecf48eebc5d407b28c5fc38c7064 /dev-python/pyicu
parentdev-python/mistune: Remove old (diff)
downloadgentoo-1b74b3ec2f10dc2e62780464154cf44f13db21a0.tar.gz
gentoo-1b74b3ec2f10dc2e62780464154cf44f13db21a0.tar.bz2
gentoo-1b74b3ec2f10dc2e62780464154cf44f13db21a0.zip
dev-python/pyicu: Bump to 2.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyicu')
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/pyicu-2.12.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index 9e70a85d94b9..d3e222063836 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1 +1,2 @@
DIST pyicu-v2.11.tar.bz2 193939 BLAKE2B 2226d9b669242980a52c1c3e734519a581c8f80cb34ff477d3602f150d290a105c86e40ea1e2f13012a81484b89bd2c50a76975683f27fcbcce9bae2475a7175 SHA512 c50e0fad3c92ccaeedf18f7ed6c31772f74b1e5bd01f00dc94b535079ce910d9033dba5ad15dabbedf6eff2034503d69d0715e0b4938ab2701450a8b641bab34
+DIST pyicu-v2.12.tar.bz2 195543 BLAKE2B ffee7f0d77495ca490047f6c1f280e47161a9dcebbf5525c8131a3876d10048f154aabfa2be98cd9bbe8e32cea2be86736cf7aa1b0193084b0b7dc36a45b861f SHA512 b182550a9491795699868908615a823e9e35220b6b43ef745a0e34563a133d2c9c2c5c8ae6e221f8c7117d310214828e8110f9e4113fd5cae7e724425de8fe84
diff --git a/dev-python/pyicu/pyicu-2.12.ebuild b/dev-python/pyicu/pyicu-2.12.ebuild
new file mode 100644
index 000000000000..44cff26c1a31
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/-/-v}
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="
+ https://gitlab.pyicu.org/main/pyicu/
+ https://pypi.org/project/PyICU/
+"
+SRC_URI="
+ https://gitlab.pyicu.org/main/pyicu/-/archive/v${PV}/${MY_P}.tar.bz2
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+DEPEND="
+ dev-libs/icu:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGES CREDITS README.md )
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test
+}