summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-29 20:03:34 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-29 20:07:49 +0300
commit88b5cff2eddb9930fa0fafa24f85a08995e4d835 (patch)
treef6cd9d979318f86c13b1854a0add67a2c4baea71 /dev-python/pylint
parentdev-python/requests: add 2.28.1 (diff)
downloadgentoo-88b5cff2eddb9930fa0fafa24f85a08995e4d835.tar.gz
gentoo-88b5cff2eddb9930fa0fafa24f85a08995e4d835.tar.bz2
gentoo-88b5cff2eddb9930fa0fafa24f85a08995e4d835.zip
dev-python/pylint: add 2.14.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pylint')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.14.4.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index cc0b0b43aab3..3ab7c5f06b5d 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -2,3 +2,4 @@ DIST pylint-2.13.9.gh.tar.gz 1123216 BLAKE2B f80e88f565595b16bba650a009bfdd6d55e
DIST pylint-2.14.1.gh.tar.gz 1270750 BLAKE2B 120cc78c3d76ccb10f88c94b5528f1ed42730b49ac7daea4c1e65cd82fa2aea2c7d77a3a26dcb84201c69afeceb538cddf1ba740af308b586624ee3d40656d49 SHA512 4be985bb78e4b2bd65a195b95fdeb2a95c59c82db2446c9c365b11f0ba57e2a3234a41865071272cb054647a15e7e1a8b48d034ca656a3a44ca509648f258c13
DIST pylint-2.14.2.gh.tar.gz 1273238 BLAKE2B c242d1686f34c1b7bdefea29a031f43dfa40de8cf33f9ab7c23c7278d2abe0df63de28693717aa68b45eeeb4a7d3b8bf442ab85181826eea2282454ba04381b5 SHA512 977b84164f87cf7cf98f761d4a4977526c7098aeef4eea4cf057d6884ff368bd7ef52e483c1eb623f026343c8c6dcd961dd5301db8dd1ac9ba2ef4edb0c517fe
DIST pylint-2.14.3.gh.tar.gz 1274008 BLAKE2B 0303cb43a4bb93419c0823dc17eb9f43a53ff1b38b0dfda185d785805839baef60b155220f6cecd43615ef783b005a44139a333df2961f736c76c513c2d6b757 SHA512 a2fd2ab2589e01188b8f587363cafba430626fffd20360cb4353a3d5a9fc5402103e74d2e4671e3d25526ed9625f77a49fc27bb0af931478f4c38ad99cf3c25a
+DIST pylint-2.14.4.gh.tar.gz 1275701 BLAKE2B a91dee4c2feb83fb98d0782cd7bbfa81752cc00c707a7b2fbeacf42c6857819d8d4cfffd4caf897af0fd38237d881cfa3b9f57a7e6eb34bee59e0203e3cdd9f3 SHA512 ee305d880052c4e1ebf939201fb5d5d52b642b5130c3314aa91eaad1a413e33e2665a935df1f7a73a3745660de3d3f0a3bed10b2871d840f73bfd2fee651d2b5
diff --git a/dev-python/pylint/pylint-2.14.4.ebuild b/dev-python/pylint/pylint-2.14.4.ebuild
new file mode 100644
index 000000000000..3737e1b624fe
--- /dev/null
+++ b/dev-python/pylint/pylint-2.14.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/PyCQA/pylint/
+"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.12[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.11.6[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.2[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+ )
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}