summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-17 19:56:39 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-17 19:56:39 +0100
commit1e26dc0c8be08fee93639a8c616de4dd91e23352 (patch)
tree97277cf5727d7ca70c9e1168ba08a0a0c039eeb2 /dev-python/pyopencl
parentdev-python/notebook: Remove old (diff)
downloadgentoo-1e26dc0c8be08fee93639a8c616de4dd91e23352.tar.gz
gentoo-1e26dc0c8be08fee93639a8c616de4dd91e23352.tar.bz2
gentoo-1e26dc0c8be08fee93639a8c616de4dd91e23352.zip
dev-python/pyopencl: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2021.2.6.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 3ad6fec049a6..8fe146384657 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,2 +1 @@
-DIST pyopencl-2021.2.6.tar.gz 450194 BLAKE2B be9d0bf653f77d33a4337deab9189a5a9031ff50526444283c6fb9f8625d0451cb211ff703b5eb86c18beebb973f8f7a7cc93da3efc6bb4e95cd533d633fde93 SHA512 b7bea4903a34104c538545c611554c1651ae7a94ee56d8c7129a88a9e547911fac085617b4238fac33534c9b981bcfdb9fabd716456a86fa428cfd42d9cb128c
DIST pyopencl-2021.2.9.tar.gz 451109 BLAKE2B a4b9b1ee1bd4f42742aa2de3acb3f5fe54771905f15dc002327a6669bf460c825c81729403df0b98537deb91ca9d0fa8dd30dd8d7e718fcc23a256b6a797484b SHA512 557bdf20df97090557f441f47b31d5b2878341fe670a4e64a563d8a464fdd5915ece651103ed17396248ab174b1895f4841e5b7ac803b8bf6286266e2c4366d6
diff --git a/dev-python/pyopencl/pyopencl-2021.2.6.ebuild b/dev-python/pyopencl/pyopencl-2021.2.6.ebuild
deleted file mode 100644
index 153702aea574..000000000000
--- a/dev-python/pyopencl/pyopencl-2021.2.6.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for OpenCL"
-HOMEPAGE="https://mathema.tician.de/software/pyopencl/
- https://pypi.org/project/pyopencl/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="examples opengl"
-
-COMMON="dev-python/numpy[${PYTHON_USEDEP}]
- >=virtual/opencl-2"
-RDEPEND="${COMMON}
- >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
-DEPEND="${COMMON}
- dev-python/pybind11[${PYTHON_USEDEP}]
- opengl? ( media-libs/libglvnd )"
-
-# The test suite fails if there are no OpenCL platforms available, and
-# even if there is one (which requires the presence of both an OpenCL
-# runtime *and* hardware supported by it - simply emerging any runtime
-# is not enough) the vast majority of tests end up skipped because by
-# default the portage user hasn't got sufficient privileges to talk
-# to the GPU.
-RESTRICT="test"
-
-python_configure_all() {
- local myconf=()
- if use opengl; then
- myconf+=(--cl-enable-gl)
- fi
-
- "${EPYTHON}" configure.py \
- "${myconf[@]}"
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}