summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-06 07:15:09 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-06 07:29:22 +0200
commit52f2777710e18d2d1b9b9778ac537c59cc00f2dc (patch)
treea6b9143ce81fffd2a8f8aa0f60039dd38796d18c /dev-python/pytest-reraise
parentdev-python/stripe: Bump to 10.2.0 (diff)
downloadgentoo-52f2777710e18d2d1b9b9778ac537c59cc00f2dc.tar.gz
gentoo-52f2777710e18d2d1b9b9778ac537c59cc00f2dc.tar.bz2
gentoo-52f2777710e18d2d1b9b9778ac537c59cc00f2dc.zip
dev-python/pytest-reraise: New package, v2.1.2
Needed for dev-python/thriftpy2. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-reraise')
-rw-r--r--dev-python/pytest-reraise/Manifest1
-rw-r--r--dev-python/pytest-reraise/metadata.xml12
-rw-r--r--dev-python/pytest-reraise/pytest-reraise-2.1.2.ebuild30
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-reraise/Manifest b/dev-python/pytest-reraise/Manifest
new file mode 100644
index 000000000000..62e7e97648d6
--- /dev/null
+++ b/dev-python/pytest-reraise/Manifest
@@ -0,0 +1 @@
+DIST pytest-reraise-2.1.2.gh.tar.gz 33487 BLAKE2B 8abb4d9524a397ab9ec8554534b26ce13ce14eaa88fe7073b57f3b4a410ff4e179a5ee7d3eb9e3e94f963a912ea0bdbc44c172e2474ab0035b8be7665b0ca756 SHA512 0095a3fd9672349a8d6628f11ac57369d48e1fdc20722215a8713ee396af563d0c95947592b5578da251b590087e479d6597bd403d1e6c2e38de4208a6db04a9
diff --git a/dev-python/pytest-reraise/metadata.xml b/dev-python/pytest-reraise/metadata.xml
new file mode 100644
index 000000000000..81510df974c7
--- /dev/null
+++ b/dev-python/pytest-reraise/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">bjoluc/pytest-reraise</remote-id>
+ <remote-id type="pypi">pytest-reraise</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-reraise/pytest-reraise-2.1.2.ebuild b/dev-python/pytest-reraise/pytest-reraise-2.1.2.ebuild
new file mode 100644
index 000000000000..a941a72240e3
--- /dev/null
+++ b/dev-python/pytest-reraise/pytest-reraise-2.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Make multi-threaded pytest test cases fail when they should"
+HOMEPAGE="
+ https://github.com/bjoluc/pytest-reraise/
+ https://pypi.org/project/pytest-reraise/
+"
+# no tests in pypi sdist, v2.1.2
+SRC_URI="
+ https://github.com/bjoluc/pytest-reraise/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-4.6[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest