summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-24 10:20:49 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-24 10:20:49 +0100
commit5f31619d8154cf9f4a4312c2574abdea7ab89098 (patch)
treee9f0b890ab878fd0e8d13e689beb9bbd8dcb17fe /dev-python/python-evdev
parentapp-admin/awscli: Bump to 1.22.80 (diff)
downloadgentoo-5f31619d8154cf9f4a4312c2574abdea7ab89098.tar.gz
gentoo-5f31619d8154cf9f4a4312c2574abdea7ab89098.tar.bz2
gentoo-5f31619d8154cf9f4a4312c2574abdea7ab89098.zip
dev-python/python-evdev: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-evdev')
-rw-r--r--dev-python/python-evdev/Manifest1
-rw-r--r--dev-python/python-evdev/python-evdev-1.5.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-evdev/Manifest b/dev-python/python-evdev/Manifest
index 7ae6ce761417..0f09b9ed2047 100644
--- a/dev-python/python-evdev/Manifest
+++ b/dev-python/python-evdev/Manifest
@@ -1 +1,2 @@
DIST python-evdev-1.4.0.tar.gz 86010 BLAKE2B 958d85f852e88a27fd22ec2511ba1367a69141f294d96f55d45fb5da176c539aef09a6c65d31be87581d0176571c7bd1ca84d580e920e460c3ca810d8efa45be SHA512 a98552bb1c5075c73ebb0a2a3a0fb241e061ed476d5342c8e8e23b3da86fa769a7d5d8027cfa243542d8b62efb89a9b1daf1c4768173295cd466714e4c53029d
+DIST python-evdev-1.5.0.tar.gz 86384 BLAKE2B 6cb6fb634d974b8ab15722def24037019590f510792fcf2bb64d8c2ffec0871ab4075674eb45a737185e4b42e39d0cd556760d51b13b5a97b79d3ee64cfd342f SHA512 27ceca723a0157fe9efa2f7aad8bb790c63d2b8d399f629eaf11fb387f3ebde0885b2d8a5297492968d625d8d9b186877e074334115e70551a1b121c8864339d
diff --git a/dev-python/python-evdev/python-evdev-1.5.0.ebuild b/dev-python/python-evdev/python-evdev-1.5.0.ebuild
new file mode 100644
index 000000000000..b24eb9bdeb46
--- /dev/null
+++ b/dev-python/python-evdev/python-evdev-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="https://python-evdev.readthedocs.io/"
+SRC_URI="
+ https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_uinput.py
+)
+
+python_configure_all() {
+ esetup.py build_ecodes \
+ --evdev-headers \
+ "${ESYSROOT}/usr/include/linux/input.h:${ESYSROOT}/usr/include/linux/input-event-codes.h"
+}
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}