summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-02 13:00:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-02 13:00:24 +0100
commitd29ed5f806326f047e852dc88f4f2eb85038d19e (patch)
treec54a0db824272ce6f8f790e86759822a2a27f019 /dev-python/recurring-ical-events
parentdev-python/hypothesis: Bump to 6.66.0 (diff)
downloadgentoo-d29ed5f806326f047e852dc88f4f2eb85038d19e.tar.gz
gentoo-d29ed5f806326f047e852dc88f4f2eb85038d19e.tar.bz2
gentoo-d29ed5f806326f047e852dc88f4f2eb85038d19e.zip
Rename dev-python/{python- → }recurring-ical-events
This is the first name following the new Python package naming policy, adjusting the package name to its PyPI name. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/recurring-ical-events')
-rw-r--r--dev-python/recurring-ical-events/Manifest1
-rw-r--r--dev-python/recurring-ical-events/metadata.xml13
-rw-r--r--dev-python/recurring-ical-events/recurring-ical-events-2.0.0.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/recurring-ical-events/Manifest b/dev-python/recurring-ical-events/Manifest
new file mode 100644
index 000000000000..a2c17c918b30
--- /dev/null
+++ b/dev-python/recurring-ical-events/Manifest
@@ -0,0 +1 @@
+DIST python-recurring-ical-events-2.0.0.gh.tar.gz 325608 BLAKE2B 386ab8a54343fb02c15938801c15b31c8c8ba6bd0888a677268625fcba5571724d53c42f9d093ea8590d6e3557c151b73f9fb532a1bea194bc6d7032e04946e9 SHA512 676bc074a4d9ddb2bf0aefe8e118eab6e80479bb0d585b9f4c50f4bd49c7adf03e484b34bdf01596bb012c903a8017644ff74026d333f13f5c7df2c4326ab18c
diff --git a/dev-python/recurring-ical-events/metadata.xml b/dev-python/recurring-ical-events/metadata.xml
new file mode 100644
index 000000000000..3c5c8d8ba58d
--- /dev/null
+++ b/dev-python/recurring-ical-events/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">niccokunzmann/python-recurring-ical-events</remote-id>
+ <remote-id type="pypi">recurring-ical-events</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/recurring-ical-events/recurring-ical-events-2.0.0.ebuild b/dev-python/recurring-ical-events/recurring-ical-events-2.0.0.ebuild
new file mode 100644
index 000000000000..77305260c9e3
--- /dev/null
+++ b/dev-python/recurring-ical-events/recurring-ical-events-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)
+
+EPYTEST_DESELECT=(
+ # a test checking if tzdata package is installed that is apparently
+ # needed for other tests, except it isn't
+ test/test_zoneinfo_issue_57.py::test_zoneinfo_must_be_installed_if_it_is_possible
+)