summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-20 16:56:07 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-20 17:03:17 +0100
commitbb4305d0744a43ef564331a6d60e41923f765dbc (patch)
tree10a986e9eb2bf5db6a163df8cc438ad049715a2c /dev-python/scikit-build
parentdev-python/xlrd: enable pypy3 (diff)
downloadgentoo-bb4305d0744a43ef564331a6d60e41923f765dbc.tar.gz
gentoo-bb4305d0744a43ef564331a6d60e41923f765dbc.tar.bz2
gentoo-bb4305d0744a43ef564331a6d60e41923f765dbc.zip
dev-python/scikit-build: Enable pypy3
Sponsored-by: Ex Makhina, Inc. <info-gentoo@exmakhina.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build')
-rw-r--r--dev-python/scikit-build/scikit-build-0.17.6.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/scikit-build/scikit-build-0.17.6.ebuild b/dev-python/scikit-build/scikit-build-0.17.6.ebuild
index 12d717e09fe7..64d867f18fce 100644
--- a/dev-python/scikit-build/scikit-build-0.17.6.ebuild
+++ b/dev-python/scikit-build/scikit-build-0.17.6.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1 pypi
@@ -52,6 +52,17 @@ src_prepare() {
}
python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # no "library" in (our install of) pypy3
+ tests/test_cmaker.py::test_get_python_library
+ )
+ ;;
+ esac
+
epytest -m "not isolated and not nosetuptoolsscm"
rm -r "${BUILD_DIR}/install$(python_get_sitedir)"/{easy-install.pth,*.egg,*.egg-link} || die
}